[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I've yet to get a 2.4 kernel to work on my DS20

On Thu, 12 Jul 2001, Edgar Denny wrote:

> I've just attempted to get the 2.4.6 kernel working on my 2 CPU
> DS20 Alphaserver. It compiled, which was an advance on 2.4.5, but
> every 2.4 kernel that I've tried, I always get the same error. The
> boot process stops with:
> Trace: 81001c
> Kernel Panic: Attempted to kill idle task!
> In idle task - not syncing
> If I disable SMP I can get a kernel to boot.
> I've tried both the default debian, and the new gcc-3.0 compiler
> with the same result.
> Can anybody help?

Yes :-)  I had the same trouble (UP2000 dual EV67 667MHz) and have a patch
on my work machine that I'll post when I get to work.  There's a function
in arch/alpha/kernel/smp.c that used to be used to set the cacheflush_time
var for the scheduler, but the 2.4 scheduler doesn't require it
anymore.  The function (smp_tune_scheduler()) is totally uneeded in 2.4
and seems to cause problems.  Removing the function call from
smp_boot_cpus() should allow you to boot SMP.

Again, I'll send you a patch when I get in (actually, I'll post it to the
list and send it in to the kernel list).


Reply to: