[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#79302 (problems with apache-ssl on Alpha)



On Mon, Dec 11, 2000 at 02:34:01PM -0600, Debian Bug Tracking System wrote:
> This is an automatic notification regarding your Bug report
> #79302: apache-ssl: apache-ssl for Alpha needs apache-common (< 1.3.13) but 1.3.14-2 is only available version,
> apache-ssl_1.3.14.2+1.42.orig.tar.gz
>   to pool/non-US/main/a/apache-ssl/apache-ssl_1.3.14.2+1.42.orig.tar.gz
> apache-ssl_1.3.14.2+1.42-1.diff.gz
>   to pool/non-US/main/a/apache-ssl/apache-ssl_1.3.14.2+1.42-1.diff.gz
> apache-ssl_1.3.14.2+1.42-1_i386.deb
>   to pool/non-US/main/a/apache-ssl/apache-ssl_1.3.14.2+1.42-1_i386.deb
> apache-ssl_1.3.14.2+1.42-1.dsc
>   to pool/non-US/main/a/apache-ssl/apache-ssl_1.3.14.2+1.42-1.dsc

There are no up-to-date binaries in the Alpha port yet, so I re-compiled and
installed apache-common and apache-ssl. The ssl module does not work.
Apache-ssl complains thus when started:
  Starting web server: apache-ssl.
  Syntax error on line 50 of /etc/apache-ssl/httpd.conf:
  Cannot load /usr/lib/apache/1.3/libssl.so into server: undefined symbol:
  RAND_egd_bytes
  /usr/sbin/apache-sslctl start: httpsd could not be started

Here are the versions I have:
ii  apache-common                    1.3.14-2                   
ii  apache-ssl                       1.3.14.2+1.42-1            
ii  libapache-mod-perl               1.24.01-2                  

I noticed that /usr/lib/apache/1.3/libssl.so is stripped; I hope this is not
the dreaded module-stripping problem that has caused so much trouble for
XFree86 4.0.1! 

-- 
Henry House
OpenPGP key available from http://hajhouse.org/hajhouse.asc

Attachment: pgpdn5AreZkgs.pgp
Description: PGP signature


Reply to: