[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ruffian ether problems

> Ok, I grabbed 2.2.18 source and am now running it. It did get rid of
> the checksum errors, but the onboard ethernet still doesn't work. So
> I'm open to other ideas?

Well, IIRC, the error messages given on your ruffian were related to checksum errors.
If the interface still doesn't work, do you have any further error messages, logs or the like ?
Of interest would be:

- /proc/pci entry
- driver used ( including optional parameters )
- ifconfig -a output
- proc/net/dev contents ( after some tests )

I really can't imagine, that *any* 21143-based card, that gets initalized by ARCS
correctly does not work in Linux.
As discussed earlier ( via chat in #alphalinux ) try fixing the media-interface to
the settings supported by your Hub/Switch/whatever. That is, try setting
10baseT, half-duplex.

Given the driver is setup correctly, no broken hardware and fixing interface characteristics,
at least I'm running out of options ;(

> TIA,
> Ron

Regards and good luck,

Thomas Weyergraf                                                kirk@colinet.de
My Favorite IA64 Opcode-guess ( see arch/ia64/lib/memset.S )
"br.ret.spnt.few" - got back from getting beer, did not spend a lot.

Reply to: