[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Weird hdparm problem


I've came across a _real_ strange thing.
On my Alpha ( UP2000, potato-TC3, dist-upgraded last friday ), I installed hdparm 3.6-1
out of curiosity, in order to test my disk-transfer rates.
I have three SCSI disks and i used the following command line, to test my first drive, right
after I installed the package:

/sbin/hdparm -Tt /dev/sda1
 Timing buffer-cache reads:   128 MB in  0.54 seconds =238.45 MB/sec
 Timing buffered disk reads:  Illegal instruction

After the command gave the illegal instruction, the _executable file_ was corrupted !
Thus,  another try with the same command-line produced:

 ./hdparm: cannot execute binary file

and file /sbin/hdparm gave:

./hdparm: data

hmm. Ok. I removed hdparm, using dpkg -r hdparm and reinstalled it. Upon the next
invocations, it worked three times (on different drives ) and after that, failed again on
/dev/sdb1. Same error, leaving the binary-file of hdparm corrupt.

Now, Ok, I use kernel 2.4.0-test11, but have not yet seen such a behaviour on
any other program. Although, I am almost certain, the faliure is related to the
kernel as being a 2.4-test series, I wonder, if anybody else ever observed something
IMHO, this is very bizarre, I have never seen any executable in any UNIX evironment
being corrupted by merely running it.

Any ideas ? Anybody willing to try either hdparm on the stock-2.2 series kernels
and under some 2.4-test series ?

I'll poke around in hdparm-sources a bit, in order to get an idea what _might_ have
happened. But believe me, this one gets me ;)

A _very_ confused
Thomas Weyergraf


Thomas Weyergraf                                                kirk@colinet.de
My Favorite IA64 Opcode-guess ( see arch/ia64/lib/memset.S )
"br.ret.spnt.few" - got back from getting beer, did not spend a lot.

Reply to: