[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New scratch build of boot-floppies (UP1000, serial console, TFTP)

Hello, all-

First off, since I'm just now delurking, it seems only fair that I
thank you all profusely.  Being able to throw an old Sparc Classic
up on the net, and, with nothing more than a jumpstart server and a
tftpboot image, put a shiny new OS on it is cool beyond description.

Thank you!

That said, I've tried playing around with these, with ... mixed results.
I can't seem to shake the feeling that I'm overlooking something obvious,
so, if I should just RTFM, please point me in its direction.

I'm trying to do a fresh install on a UDB w/ 24M of memory.

Initially, I tried booting from a rescue floppy, but that consistently
fails part-way through reading linux.gz.  The point at which it hangs
is not consistent, either, although some of the eight or so rescue
floppies I made seem to do better overall than others.  I've tried
both the 03/08 disk images and these ones without success.  In all the
cases, I used dd on my ultra/5 (Solaris 2.6) to make the disks from
the images.  I suspect that I just need a sound beating with a clue
stick... any volunteers?

With that in mind, the prospect of a boot over ewa0 seemed very

On 20 Mar 2000, David Huggins-Daines wrote:

> Hi,
> http://www.debian.org/~dhd/disks-alpha-20000319/
> Things of note:


> 2) Serial console installations should basically work now (they were
>    rather broken on all archs, and in fact not really enabled on Alpha
>    at all).  You just have to boot with console=ttyS0 (I really tried
>    to find a way to hack around this in aboot, but the CTB entry
>    pointed to by the TTY_DEV environment variable in SRM comes up as
>    "multifunction" regardless of whether I boot using serial or
>    graphics console :P)

Just out of curiosity, is the console=ttyS0 option a new feature of
the kernel, or was it always there?

> 3) Nikita's tftpboot.img stuff is built by default (I'm considering
>    just incorporating the relevant parts of the kernel source tree in
>    the boot-floppies CVS, as they're pretty small and we have to patch
>    them anyway).  There's also a root.tar.gz which isn't particularly
>    useful since I didn't put in a netbootable kernel image - but that
>    can certainly be arranged (we need to include objstrip in the aboot
>    package)

I've tried using the tftpboot.img to get an install going on my UDB,
but haven't gotten it to work.  Here's the scenario:

I have a bootp/tftp server running on a Sparc Classic (frozen, thanks
again :), and I renamed tftpboot.img and put it in /tftpboot.  I've set
ewa0_protocols to bootp on the UDB and configured bootp on the classic
with the UDB's ethernet address and related information.  When I run a
'boot ewa0', it grabs the tftpboot.img fine, but, when it's done, the
SRM console resets.  It looks like its generating some errors, but they
scroll past too quickly for me to see.  Unlike the DS10 hangs mentioned
below, this seems to be quite consistent.

Am I correct in assuming that the boot file (bf) in bootp should
be the tftpboot.img (as renamed)?

Is the root.tar.gz file needed on the server, and, if so, where?
If it is needed, does the fact that it "isn't particularly useful"
preclude booting over the network?

Again, many thanks to all the developers and maintainers.  I figure
it would be counter-productive to spam this to all the lists, so
tell all your friends they have another big fan.


Reply to: