[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bash coredumping?


Today, I noticed that woody is missing some packages or has some
package versions older than potato, so I added lines for frozen (in
addition to the ones for unstable) in my sources.list, ran update and

But, bash (!) is now coredumping in some cases.  For instance, teh cvs
postinst, which is all shellscripts.  If I run
/var/lib/dpkg/info/cvs.postinst configure, it crashes with coredump.
If I run bash -c /var/lib/dpkg/info/cvs.postinst configure, it works.
I am puzzled.  Also tex is demonstrating some of the same problems.
Ideas anyone?  Here are the messages.

Setting up tetex-bin (1.0.6-3) ...
mktexlsr: Updating /var/lib/texmf/ls-R... 
mktexlsr: Updating /var/spool/texmf/ls-R... 
mktexlsr: Done.
Running initex. This may take some time. ...
/usr/bin/texconfig: line 1: 27633 Segmentation fault      (core dumped) fmtutil --all
/usr/bin/texconfig: line 2: 27659 Segmentation fault      (core dumped) texlinks ${SILENT_TEXLINKS+-s}
/var/lib/dpkg/info/tetex-bin.postinst: line 82: 27594 Segmentation fault      (core dumped) $TEXCONFIG_P init >$TEMPFILE
dpkg: error processing tetex-bin (--configure):
 subprocess post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of tetex-dev:
 tetex-dev depends on tetex-bin; however:
  Package tetex-bin is not configured yet.
dpkg: error processing tetex-dev (--configure):
 dependency problems - leaving unconfigured
Setting up cvs (1.10.7-6) ...
/var/lib/dpkg/info/cvs.postinst: line 18: 27690 Segmentation fault      (core dumped) /usr/sbin/cvsconfig -s
dpkg: error processing cvs (--configure):
 subprocess post-installation script returned error exit status 139
Errors were encountered while processing:

John Goerzen   Linux, Unix consulting & programming   jgoerzen@complete.org |
Developer, Debian GNU/Linux (Free powerful OS upgrade)       www.debian.org |
The 96,998,970th prime number is 1,973,807,519.

Reply to: