[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

alpha can't load ramdisk, image to big

    I have a sx164 motherboard with a 533Mhz alpha. I installed redhat 6
on it a while ago and since then decided I wanted my debian on it
aswell. I got the proper rescue disk, and root1440.bin, dd the images on
disks and tryied to boot.
MILO boot fd0:/linux load_ramdisk=1
It boots up all nice and happy and then asks me to change disks. I out
in the root image and it give me an error saying that the image is too
big. Even after adding the option ramdisk_size=32768 which should make
the maximun ramdisk size 32 megs it give me this error. I have tried re
writing the disks with no luck. I also tried a different kernel with no
luck. I also tried to have the disk with the root1440.bin image be
mounted as the root but I get a kernel panic because it can't mount the
disk. The only thing I can find that could possible be the cause of all
this is that during boot the kernel detects my floppy as a 2.88 meg
drive, which is not and the alpha bios detects it as a 1.44 meg drive.
Also the redhat kernel I used to install redhat did the same thing but
its root disk worked fine. I have a cd so if someone can tell me how to
boot of the cd and have it load a ramdisk that would be great. but
anyhelp would be greatly appreciated.

Thank You

Reply to: