[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Notes on installing an AlphaServer 1000A 5/333

This weekend I was asked to install linux on an AlphaServer 1000A 5/333
system. I had found out that milo didn't support this system, so I
needed to use SRM and aboot.  Finding this out was a pain, as
www.alphalinux.org was not reachable for most of Thursday - Sunday! It
would be cool to have stuff like the SRM FAQ mirrored on the debian
site; it's not like it gets updated regularly (it's dated 1996!).

Anyway, I made the error of making a rescue floppy as I could boot off
the cdrom :-). However, here are a couple of comments on Loic's
http://lhpca.univ-lyon1.fr/axp/README :

- step 2c: this also goes for "noritake-p(rimo)".
           The cdrom seems to almost always be on dka4, and it's
           confusing that the next line says to check that the cdrom is
           in fact "dkc0" whereas the line above has "dka0" as example.
           The link between the two is not directly apparent as they are
           sufficiently different thanks to the "dkc0" typo.

           It then goes on to say:

            You will get an "aboot>" prompt, type:

                aboot><boot-path>/linux root=/dev/<root-device> load_ramdisk=1 prompt_ramdisk=1"

           It's not apparent what <boot-path> in the above command may
           be. In my innocence I tried "dka4/linux" and variations on
           this theme, but apparently it's simply the path to the linux
           kernel on the device (or a partition number when booting from
           disk).  I expected to be able to specify here whether it was
           booting from cdrom or disk, as aboot then says "booted from
           'SCSI x x x x', assuming '/dev/scd0'". I'd have liked to be
           able to convince aboot not to assume anything, but nothing
           worked. Anyone any suggestions on this item?

- step 5:  about using fdisk and BSD labels instead of PC-style partitions:
           The fdisk on slink, when put into BSD mode, does not tell the
           kernel to re-read the partition table after writing the table
           to disk! This had me confused a bit until I tried rebooting
           after using fdisk, and presto, the kernel saw the new layout.
           I don't know whether there's something specific about the BSD
           table so that the kernel can't re-read it, or whether fdisk
           simply omits the code in the case of BSD tables. However,
           until this is changed, the README definitely needs to be

- step 6:  I could not get aboot to boot from the hard disk; it loaded,
           but then "assumed" that de device was scd0 (see above).

In general: It would be nice if some more hints about how to configure
           SRM could be given, e.g. setting the environment variables in
           SRM so that you don't have to supply the boot flags manually
           every time. Additionally the SRM/aboot and MILO info is mixed
           quite a bit; it would be less confusing if the info was is
           separate sections.

Another problem was that the Qlogic scsi adapter hung during probing of
the scsi bus when more than one disk was inserted, and that the adaptec
(which didn't have any trouble with probing, although I can't really
remember that it tried to :-) wasn't recognized by SRM... So for the
time being I'm booting from the cdrom.

Also I had lots of segmentation violation problems (bash dying, vim
dying, apache dying, ...) which is probably due to bad memory, although
the system had apparently been running NT more or less successfully...
Any hints?

Note that I don't have access to this system, or at least not readily,
so I can't really try things quickly.

On the bright side, I had configured the three additional 4GB disks as a
RAID-0 striped disk with md, and that works great!

Paul Slootman
home: paul@wurtel.demon.nl | work: paul@murphy.nl | debian: paul@debian.org
http://www.wurtel.demon.nl | Murphy Software,   Enschede,   the Netherlands

Reply to: