[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dependency check on hamm for alpha

Recently I did an integrity check over the dependencies in the
hamm/main/i386 distribution.  Christopher C. Chimelis asked me to do a
similar scan for alpha.  Here are the results.

I have placed the Python scripts that generate this on master,
~dark/depcheck/.  I make no particular claims about their quality :-)

Richard Braakman

Cannot satisfy with packages in main:

abuse-lib: recommendation abuse (>= 2.00)
ascd: dependency xpm4 (>= 3.4j-0)
ascdc: dependency xpm4 (>= 3.4j-0)
asmixer: dependency xpm4 (>= 3.4j-0)
boot-floppies: dependency libc6-pic
emacspeak: dependency tclx76 | tclx75 | tclx74 | tclx
eterm-bg: recommendation eterm
gltt-bin: dependency glutg3 (>= 3.6-1)
gltt1: dependency glutg3 (>= 3.6-1)
icon-ipl: recommendation icont | iconc
javalex: dependency java-virtual-machine
ldso: dependency libc6
libc6-doc: dependency libc6 (= 2.0.7pre1-4)
libc6.1-dev: dependency kernel-headers-2.0.32 (>= 2.0.32-2)
libdb1-dev: dependency libc5-dev
libgdbm1: dependency libc5 (>= 5.2.16-1)
libpam0: dependency libpam-util (>= 0.56-2)
loadmeter: dependency xlib6 (>= 3.3-0)
locale-ja: dependency libc6
locale-ko: dependency libc6
mctools-lite: dependency xpm4 (>= 3.4j-0)
ncurses3.0: dependency libc5
nextawg: dependency ldso (>= 1.8.9-1)
p2c: dependency libp2c1
pgapack: dependency libc6
php3-doc: dependency php3
pstoedit: recommendations xfig, tgif
qpage: recommendation cfgtool
setcd: dependency libc6
slang0.99.34-dev: dependency libc5-dev
svgalib-bin: dependency svgalibg1
svgalibg1-dev: dependency svgalibg1 (= 1:1.2.13-1)
tcl76-altdev: dependency libc5-altdev (>= 5.4.33-5)
tcl76: dependency libc5 (>= 5.4.33-5)
tetex-base: recommendation tetex-nonfree
tk42: dependency xlib6 (>= 3.2-0)
tkhylafax: dependency hylafax-client
xaw95g: dependency ldso (>= 1.8.9-1)
xslib: dependency xlib6-dev
xview-clients: recommendation xtoolplaces
zircon: dependency libc6

Cannot satisfy with required packages:

bsdutils: recommendation bsdmainutils
dpkg: pre-dependency libstdc++2.8 (>= 2.90.26-1)
modconf: dependency whiptail
perl-base: pre-dependency libgdbmg1
procps: recommendation psmisc

Cannot satisfy with important packages:

dpkg-dev: recommendations patch (>= 2.2-1), gcc, make
groff: dependency libstdc++2.8
man-db: dependency libdb2 (>= 2.3.16)

Cannot satisfy with standard packages:

cvs: dependency zlib1g
dpkg-ftp: dependency libnet-perl
emacs19: dependencies liblockfile0 (>= 0.1-1), liblockfile0
emacs20: dependencies liblockfile0, liblockfile0 (>= 0.1-1)
lynx: dependency zlib1g
mh: dependency liblockfile0 (>= 0.1-1)
ppp-pam: dependencies libpam0g, ppp (= 2.3.3-5)
tetex-base: pre-dependency dpkg-perl
tetex-bin: dependency zlib1g
tetex-bin: pre-dependency dpkg-perl
tetex-bin: recommendations dialog, tetex-extra

Cannot satisfy with optional packages:

boot-floppies: dependency slang0.99.38-pic
dialdcost: dependency diald
gs: dependency svgalibg1 | svgalib-dummyg1
lockvc: dependency svgalibg1 | svgalib-dummyg1
python-mpz: dependency gmp2 (>= 2.0.2)
rpm2html: dependency rpm
tetex-extra: pre-dependency dpkg-perl

Cannot satisfy with extra packages:

Cannot satisfy without packages in oldlibs:

aumix: dependency libgpm1 (>= 1.12-1)
cam: dependency ncurses3.0
epic: dependency ncurses3.0
mtr: dependency ncurses3.0
sirc: dependency ncurses3.0
timidity: dependency ncurses3.0

Cannot satisfy with packages in base:

whiptail: dependency newt0.21

To UNSUBSCRIBE, email to debian-alpha-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: