[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg segfaultage

Howdy.  dpkg has been segfaulting on me, and though I've been trying for
about a week to find out why, I can't.  I've tried hand-installing (with
ar) the dpkg from slink (same ver), a new libc6, etc.  But all to no

It segfaults on all packages, the following is output from
dpkg -i dosfstools_1.0-9.1.deb

Here's what I get in my kernel log:

May  6 09:54:56 brigit kernel: dpkg: memory violation at pc=12000d2c0 rp=1555566efa0 (bad address = 000000d0) 

It's the same address each time.  An strace reveals this:

write(4, "Package: dosfstools\nStatus: ins"..., 575) = 575
ftruncate(4, 575)                       = 0
fsync(4)                                = 0
close(4)                                = 0
munmap(0x15555568000, 8192)             = 0
rename("/var/lib/dpkg/updates/tmp.i", "/var/lib/dpkg/updates/0003") = 0
open("/var/lib/dpkg/updates/tmp.i", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 4
fstat(4, {st_mode=01, st_size=1525620889, ...}) = 0
mmap(0, 4831834104, PROT_WRITE|PROT_EXEC|0x1b0, 0 /* MAP_??? */, 2, 0) = 0x15555568000
write(4, "#padding\n#padding\n#padding\n#p"..., 4608) = 4608
lseek(4, 0, SEEK_SET)                   = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

I tried removing /var/lib/dpkg/updates/tmp.i just in case, but it still
died.  GDB doesn't give anything useful (no debugging symbols) and I
can't build a new dpkg because it started crashing right as I was trying
to install gcc.deb.

This is a hamm installation, Linux 2.0.30, on an Alpha UDB.  I can get
packages installed (I think!) by first doing dpkg -i and then dpkg

Neale Pickett, sysprog, sysprog     Contact information in headers
Los Alamos National Laboratory, Network Engineering Group (CIC-5)

To UNSUBSCRIBE, email to debian-alpha-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: