[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Braille embossing on Debian Bullseye

Hi all

I am trying to set up my workstation to print/emboss braille over my Index
Everest V5. I installed the printer, thanks for the straight-forward and
well-integrated experience!

However, I have a few issues.

1. Printing Graphics

I have tried to print the Debian logo from debian.org using `lp`. (PNG file).
Error.log says this:

E [16/Apr/2022:15:11:58 +0200] [Job 12] Job submission timed out.
E [16/Apr/2022:15:11:58 +0200] [Job 12] Aborting job because it has no files.
E [16/Apr/2022:15:24:17 +0200] [CGI] ippfind (PID 19352) stopped with status 1!
E [16/Apr/2022:15:24:17 +0200] [cups-deviced] PID 19344 (driverless) stopped with status 1!

The embosser stopped after 2/3rd of the page and refused to interact with to
any key press. I had to force-reboot it. Any idea how to get more helpful
I read the cups-filters docs in /usr, but it looked as if all the conversion
magic for the image would be done in the background.

2. Text embossing

I tried to print some pages of text and got a few lines in the error log
saying that the conversion pipeline failed.

E [16/Apr/2022:14:50:28 +0200] [Job 9] text conversion pipeline pdftotext -raw - - | file2brl -p -Chyphenate=yes -CliteraryTextTable=en-us-brf.dis,en_GB.tbl,de-g2.ctb,braille-patterns.cti  -CinputTextEncoding=UTF8 -CbraillePages=yes -CbraillePageNumberAt=bottom -CpageNumberBottomSeparateLine=yes -CprintPages=yes -CprintPageNumberAt=top -CpageNumberTopSeparateLine=yes -CpageSeparator=yes -CpageSeparatorNumber=yes -CcontinuePages=yes -CcellsPerLine=29 -ClinesPerPage=27  |  | addmargins failed

The embosser just emitted an empty page.
It looks a bit worrying that there are two pipes in the conversion command.
Dissecting this further, I figured out that some translation tables seem to be

$ echo 'Hello, world!' |strace file2brl -p -Chyphenate=yes -CliteraryTextTable=en-us-brf.dis,en_GB.tbl,de-g2.ctb,braille-patterns.cti  -CinputTextEncoding=UTF8 -CbraillePages=yes -CbraillePageNumberAt=bottom -CpageNumberBottomSeparateLine=yes -CprintPages=yes -CprintPageNumberAt=top -CpageNumberTopSeparateLine=yes -CpageSeparator=yes -CpageSeparatorNumber=yes -CcontinuePages=yes -CcellsPerLine=29 -ClinesPerPage=27
[output without strace, config cropped]
:2: invalid literaryTextTable
Cannot open main table (null)
[end of output of strace]
openat(AT_FDCWD, "/usr/share/liblouis/tables/en-us-g2.ctb", O_RDONLY) = 4
openat(AT_FDCWD, "/usr/share/liblouis/tables/en-us-g1.ctb", O_RDONLY) = 5
openat(AT_FDCWD, "/usr/share/liblouis/tables/en-chardefs.cti", O_RDONLY) = 6
openat(AT_FDCWD, "/usr/share/liblouis/tables/spaces.uti", O_RDONLY) = 7
openat(AT_FDCWD, "/usr/share/liblouis/tables/loweredDigits6Dots.uti", O_RDONLY) = 7
openat(AT_FDCWD, "/usr/share/liblouis/tables/latinLetterDef8Dots.uti", O_RDONLY) = 7
openat(AT_FDCWD, "/usr/share/liblouis/tables/en-us-compbrl.uti", O_RDONLY) = 6
openat(AT_FDCWD, "/usr/share/liblouis/tables/en-us-emphasis.uti", O_RDONLY) = 6
openat(AT_FDCWD, "/usr/share/liblouis/tables/litdigits6Dots.uti", O_RDONLY) = 6
openat(AT_FDCWD, "/usr/share/liblouis/tables/braille-patterns.cti", O_RDONLY) = 6
stat("/usr/share/liblouisutdml/lbu_files/en-us-brf.dis,en_GB.tbl,de-g2.ctb,braille-patterns.cti", 0x7fffd96dd9b0) = -1 ENOENT (No such file or directory)

It seems as if the format to pass multiple braille tables is wrong. The list
seems to be interpreted like a literal file name. Any suggestions on how to
fix this?


Attachment: signature.asc
Description: PGP signature

Reply to: