[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: loss of speech in speakup when switching between console and gui

On 04/11/18 18:36, Samuel Thibault wrote:
Keith Barrett, le dim. 04 nov. 2018 18:32:41 +0000, a ecrit:
On 04/11/18 13:48, Didier Spaier wrote:
On 04/11/2018 14:37, Keith Barrett wrote:

On 03/11/18 19:54, Didier Spaier wrote:

I should have stated that this binary is a 64-bit one.

Maybe you have a 32-bit system?
No, I have a 64-bit system.
Just thinking about it later, could it be a permissions/ownership issue?
Just in case, try again, this time typing as root after having copied the file:
chown root:root /usr/bin/espeakup
chmod 755 /usr/bin/espeakup.

Success, it must have been permissions.
I have been switching between X and the console and so far, after a few
hours, no crashes at all.

Thank you Didier for your efforts, a long standing issue solved for me, can
we get the change included in debian?

Not that simply since as I mentioned the setup that Didier uses is not
the default setup configured by the pulseaudio package. That needs to be
discussed with pulseaudio maintainers.

Hello Samuel,
Until the issues can be resolved, is it possible then when installing using speech to not have the install install pulseaudio and to add Didier's modification? To recap, this means that switching between the console and graphical interface works as expected, as long as pulseaudio is not present. I know there may be arguments to retain pulseaudio but until it can be made to work, it is an obsticle to an accessible system.

I am concerned that unless the issues are solved by the release of buster, we are shipping a non-accessible system.

Reply to: