[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#797891: marked as done (dasher: Segfault on toggling "Control Mode" check box)

Your message dated Thu, 26 Jan 2017 15:24:13 +0100
with message-id <6bb31af8-c28d-12b6-19e6-980dc335e1d2@debian.org>
and subject line Fwd: Re: Bug#797891: dasher: Segfault on toggling "Control Mode" check box
has caused the Debian Bug report #797891,
regarding dasher: Segfault on toggling "Control Mode" check box
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

797891: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=797891
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: dasher
Version: 4.11+git20130508.adc653-2
Severity: normal

Dear Maintainer,

After starting dasher, going to Edit -> Preferences... -> Application,
and then activating and deactivating the "Control Mode" checkbox, dasher

This also happens if i activate control mode, click "Close" in the bottom right
of the dialog,
reopen the Dasher Prefrences and untick Control Mode.



-- System Information:
Debian Release: 8.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_AT.UTF-8, LC_CTYPE=de_AT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages dasher depends on:
ii  dasher-data          4.11+git20130508.adc653-2
ii  gconf-service        3.2.6-3
ii  libatk-adaptor       2.14.0-2
ii  libatk1.0-0          2.14.0-1
ii  libatspi2.0-0        2.14.0-1
ii  libc6                2.19-18
ii  libcairo-gobject2    1.14.0-2.1
ii  libcairo2            1.14.0-2.1
ii  libdbus-1-3          1.8.18-0+deb8u1
ii  libexpat1            2.1.0-6+deb8u1
ii  libgcc1              1:4.9.2-10
ii  libgconf-2-4         3.2.6-3
ii  libgdk-pixbuf2.0-0   2.31.1-2+b1
ii  libglib2.0-0         2.42.1-1
ii  libgtk-3-0           3.14.5-1
ii  libice6              2:1.0.9-1+b1
ii  libpango-1.0-0       1.36.8-3
ii  libpangocairo-1.0-0  1.36.8-3
ii  libsm6               2:1.2.2-1+b1
ii  libspeechd2          0.8-7
ii  libstdc++6           4.9.2-10
ii  libx11-6             2:1.6.2-3

dasher recommends no packages.

dasher suggests no packages.

-- debconf-show failed

--- End Message ---
--- Begin Message ---
fixed 797891 5.0.0~beta~repack-2

-------- Weitergeleitete Nachricht --------
Betreff: Re: Bug#797891: dasher: Segfault on toggling "Control Mode"
check box
Datum: Thu, 26 Jan 2017 14:24:21 +0100
Von: Thibaut Paumard <thibaut@debian.org>
Organisation: Debian GNU/Linux
An: Simon Kainz <skainz@debian.org>, 797891@bugs.debian.org

Le 26/01/2017 à 14:16, Simon Kainz a écrit :
> Hello,
> I just build 5.0.0~beta~repack-2 and tested it, it works.
> It tried toggling it on/off, also fast, but could not crash dasher.
> So this bug may be closed.

Thanks for your feedback.

Regards, Thibaut.

> Thanks & Bye,
> Simon
> Am 2017-01-25 um 16:52 schrieb Thibaut Paumard:
>> control: tag -1 confirmed
>> Dear Simon,
>> I recently adopted dasher and am now processing the backlog of bug reports.
>> I can confirm the SEGFAULT, but only if I click repeatedly and fast on
>> the toggle.
>> In you experience, it the bug easy to reproduce or do you have to
>> insist? Does the bug break some functionality, or is it merely an
>> inconvenience that you have to restart dasher? Could you also try the
>> new version (currently in unstable, hopefully in testing within a coupld
>> of days): 5.0.0~beta~repack-2 and tell me whether it behaves better for
>> you? (I have tried and seen that the SEGFAULT is possible to trigger).
>> Regards, Thibaut.

--- End Message ---

Reply to: