[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

My experience and some issues with the accessibility of the Jessie/testing desktop

I did an install of Jessie today from one of the netboot images. I did
an install of the xfce desktop and lightdm display manager which I
believe is the default at this point. I know that from prior experience,
by default, xfce doesn't load the accessibility modules for gtk but they
can either be sourced in a profile or there is a checkbox in the
accessibility settings for xfce that loads the modules. I chose to check
the accessibility box as I know from prior experience that this works
reliably. If XFCE does get chosen as the default desktop, I wonder if
checking this box could be part of the accessibility profile in the
installer for Debian if the desktop task is chosen. I know that this can
be done on the command line using xfconf. After I restarted the machine,
I got the expected level of accessibility from XFCE. For those who don't
know, the current state of accessibility in XFCE allows one to read the
menus and some of the programs that are included with the desktop.
Currently the panel is completely inaccessible with Orca. Thunar (XFCE's
file manager) has some accessibility issues that prevent access to the
desktop but if you replace this with pcmanfm from the lxde desktop, you
will find these are resolved as of the new version that was released a
few weeks ago. All the things I have described so far are upstream and
are not related specifically to Debian. One problem I have found that I
have only seen in debian is inaccessibility of the mozilla apps in a
non-gnome environment. I tried Iceweasel from the Debian repositories.
When this would not work, I tried downloading a precompiled version from
the Mozilla site and orca still wouldn't talk. It appears orca is not
even seeing the application because when using orca -l which gives a
list of application orca sees, the Mozilla apps are not listed at all.
It appears that others are having a similar issue see
https://bugzilla.mozilla.org/show_bug.cgi?id=956684. One of the things
mentioned in this bug report is that Mozilla apps check for an
accessibility value using dbus to enable their accessibility. I checked
this value in my environment and the value was set to true. I wonder if
the issue could be related since ubuntu is downstream from debian. I
have not had this issue in Gentoo or Arch with XFCE so I guess at this
point, a next step would be to figure out what is different in the
Debian environment. I will do some poking around in my Gentoo, Arch, and
Debian environments and see if I can spot some differences but I thought
at least posting this hear could maybe help determine if others are
having this issue, and make others aware. I will also install a full
Gnome environment on Debian to see if I can get Mozilla apps talking
there. Any advice related to this issue would be greatly appreciated.

Reply to: