[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [PATCH] enable libao support in speech-dispatcher for debian squeeze

Samuel Thibault wrote:
> I was not aware of this bug.

Most of the discussion took place in May, mostly under the thread:
  Re: Cut-and-Paste in AT in Speakup?

For example, 22 May I wrote:
  I wrote:
  > I tried ed, and it crashes just as horribly as edbrowse:
  >   BUG: scheduling while atomic: /swapper/0/0x10010000
  > and gruesome system hang; only the off-switch works.
  Pasting into even The Simplest Imaginable Perl Program:
    perl -e '$s=<>'
  likewise instantly crashes the kernel:
    BUG: scheduling while atomic: /swapper/0/0x10010000
  and power-off is the only option :-(  Likewise with
    perl -e '@s=<>'
    perl -e '$s=<STDIN>'
  and all other variations, like
  and therefore likewise with my edpager:
  in fact it's hard to imagine any Perl script working at all.
  (Pasting from gpm, OTOH, works just fine into all these things.)
  Considering debian squeeze is supposed to be "stable",
  this seems highly release-critical...  Has it been logged with

But I never got any answers to that. On 23 May I wrote:
  pj@pjb.com.au wrote:
  > Pasting into even The Simplest Imaginable Perl Program:
  >   perl -e '$s=<>'
  > likewise instantly crashes the kernel:
  Chris Brannon writes:
  > I'm not seeing the same behavior over here.
  And ed and edrowse ? are you able to paste into ed and edbrowse ?
  > Exactly which kernel version are you running?  And what does
  > cat /sys/accessibility/speakup/version   tell you?
  box8 (debian) ~> uname -r
  box8 (debian) ~> cat /sys/accessibility/speakup/version
  Speakup version 3.1.5
  soft synthesizer driver version 2.6

On 28 May I tried again:
  Something which might help: I can't paste into the STDIN of anything,
  not even cat, but I am able to paste directly into the shell, or
  into a shell built-in.  E.g. if "Gloop" has been marked and cut:
    box8 (debian) ~> echo Gloop     # pasting the Gloop :-)
    box8 (debian) ~> cat            # now paste the Gloop :-(
      [NNNN.NNNN] BUG: scheduling while atomic: /swapper/0/0x10010000
  (dialogue reconstituted by hand for obvious reasons :-)
   happily, we have journalling filesystems these days...)
  I'm using (debian stable):
    GNU bash, version 4.1.5(1)-release (i486-pc-linux-gnu)

and Chris replied:
  pj@pjb.com.au writes:
  >  [NNNN.NNNN] BUG: scheduling while atomic: /swapper/0/0x10010000
  Yeah, this does help.
  As I said, no problems pasting on this box.  Pasting into edbrowse
  is fine.  So I had a look at selection.c, from the speakup source.
  We test to see whether we're in atomic context, in the
  speakup_paste_selection function.  Apparently, that isn't working.
  Also see the comment at the top of that function.
    /* TODO: move to some helper thread, probably.  That'd fix having
     * to check for in_atomic().  */
  This code needs to be rewritten.
  I might be able to take a look at it in another week or more,
  after I'm done moving.

So presumably Chris Brannon is working on it. (But if he can't
reproduce the crash, maybe it's hard to fix.) John Covici added:
  I am having lots of crashes with speakup and recent kernels --
  I know this is one of the things which is causing this to happen,
  I don't know if there are any other problems because the crashes
  don't necessarily happen when I am pasting.

Igor Gueths also contributed to the thread, and of course also
William F. Acker:
  A way around this is to ssh to localhost. I prefer localhost6,
  but that's just me.

Also Frost (Michael Ferranti) implied there are other problems:
  I can avoid the crashes pretty easily, after having been a 
  Windows user (shameless dig).  It's the garbled speech out of the 
  software synth that drives me nuts.  I run any text file through lynx, 
  more, or less, or just chat on IRC with irssi, and about two or three 
  screenfuls into the file, speakup starts garbling things, usually right 
  in the middle of the screen, as if, say, lines 5 through 10 are being 
  affected and not the rest.  It didn't happen with the 2.36 kernel in 
  Debian squeeze with the LiteTalk (LTLK) module, but did in the software 
  synthesizer.  ...

Hope this helps,
Peter Billam

http://www.pjb.com.au       pj@pjb.com.au      (03) 6278 9410
"Was der Meister nicht kann,   vermöcht es der Knabe, hätt er
 ihm immer gehorcht?"   Siegfried to Mime, from Act 1 Scene 2

Reply to: