[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#568858: marked as done (gnome-mousetrap: doesn't work (opencv 1 → 2 problem?))

Your message dated Mon, 21 Jun 2010 01:02:31 +0000
with message-id <E1OQVPD-0001wU-8N@ries.debian.org>
and subject line Bug#568858: fixed in gnome-mousetrap 0.4-1
has caused the Debian Bug report #568858,
regarding gnome-mousetrap: doesn't work (opencv 1 → 2 problem?)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

568858: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=568858
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Subject: gnome-mousetrap: doesn't work (opencv 1 → 2 problem?)
Package: gnome-mousetrap
Version: 0.3+zgit2872572a-1
Justification: renders package unusable
Severity: grave

gnome-mousetrap doesn't work for me. I see no image from webcam, the
mouse pointer doesn't move. The following error message is shown when
running in a terminal.

It may be a problem with the new OpenCV 2.0 library.


steko@gibreel:~$ mousetrap 
DEBUG: mousetrap.mouse -> GNOME desktop has been detected
DEBUG: mouseTrap -> Settings have been loaded
DEBUG: mouseTrap -> DBus Service has been started
DEBUG: scripts -> Mousetrap holdProfile Profile has been loaded
ERROR: scripts -> The Profile load failed
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.5/mouseTrap/scriptHdlr.py", line 57, in _loadThirdProfiles
    modes[prof.setName] = prof.Profile
AttributeError: 'module' object has no attribute 'Profile'
DEBUG: scripts -> Mousetrap dragProfile Profile has been loaded
DEBUG: scripts -> Mousetrap screenProfile Profile has been loaded
ERROR: mainGui -> All arguments must be INT
ERROR: mainGui -> All arguments must be INT
DEBUG: events -> New Area Listener Added
DEBUG: events -> New Area Listener Added
DEBUG: scripts -> Profile Started
DEBUG: mouseTrap -> MainGui has been started
DEBUG: ocvfw -> cmStartCamera: Camera Started
DEBUG: mouseTrap -> Camera Module has been started
DEBUG: mouseTrap -> Events handler has been started
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.5/mouseTrap/cam.py", line 142, in _checkImg
    self.cmQueryCapture( flip = self.settings.getboolean( "cam", "flipImage" ) )
  File "/usr/lib/pymodules/python2.5/mouseTrap/ocvfw.py", line 273, in cmQueryCapture
    self.img.origin     = frame.origin
  File "/usr/lib/pymodules/python2.5/opencv/cv.py", line 2097, in <lambda>
    __setattr__ = lambda self, name, value: _swig_setattr(self, CvMat, name, value)
  File "/usr/lib/pymodules/python2.5/opencv/cv.py", line 48, in _swig_setattr
    return _swig_setattr_nondynamic(self,class_type,name,value,0)
  File "/usr/lib/pymodules/python2.5/opencv/cv.py", line 41, in _swig_setattr_nondynamic
    if method: return method(self,value)
RuntimeError:  openCV Error:
        Status=The function/feature is not implemented
        function name=CvMat_origin_get
        error message=IplImage is replaced by CvMat in Python, so its fields are read-only
DEBUG: events -> Event's handler has been stoped

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnome-mousetrap depends on:
ii  python                   2.5.4-9         An interactive high-level
ii  python-opencv            2.0.0-3+b1      Python bindings for the
computer v
ii  python-pyatspi           1.28.1-3        Assistive Technology
Service Provi
ii  python-support           1.0.6           automated rebuilding
support for P
ii  python-xlib              0.14+20091101-1 Interface for Python to the
X11 Pr

gnome-mousetrap recommends no packages.

gnome-mousetrap suggests no packages.

-- no debconf information
Stefano Costa
http://www.iosa.it/ Open Archaeology

Attachment: signature.asc
Description: This is a digitally signed message part

--- End Message ---
--- Begin Message ---
Source: gnome-mousetrap
Source-Version: 0.4-1

We believe that the bug you reported is fixed in the latest version of
gnome-mousetrap, which is due to be installed in the Debian FTP archive:

  to main/g/gnome-mousetrap/gnome-mousetrap_0.4-1.debian.tar.bz2
  to main/g/gnome-mousetrap/gnome-mousetrap_0.4-1.dsc
  to main/g/gnome-mousetrap/gnome-mousetrap_0.4-1_all.deb
  to main/g/gnome-mousetrap/gnome-mousetrap_0.4.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 568858@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Samuel Thibault <sthibault@debian.org> (supplier of updated gnome-mousetrap package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA256

Format: 1.8
Date: Mon, 21 Jun 2010 00:34:14 +0200
Source: gnome-mousetrap
Binary: gnome-mousetrap
Architecture: source all
Version: 0.4-1
Distribution: unstable
Urgency: low
Maintainer: Debian Accessibility Team <debian-accessibility@lists.debian.org>
Changed-By: Samuel Thibault <sthibault@debian.org>
 gnome-mousetrap - Head tracked mouse control
Closes: 568858
 gnome-mousetrap (0.4-1) unstable; urgency=low
   * New git snapshot (Closes: Bug#568858).
   * Switch to 3.0 (quilt) format and bz2 compression.
   * debian/control: Bump Standards-Version to 3.8.4 (no change needed).
   * debian/control: Now build-depend on python2.6-dev, and on python-gnome2
     (>= 2.28.0-2) since gnome-mousetrap now needs python2.6. Depend on
     python-opencv (>= 2.0.0-4) to get python2.6 build.
   * debian/rules: Set PYTHON to python2.6.
   * debian/pyversions: Set to 2.6-.
 49f2c500ab1d44e266247b225472001f6773a392 1518 gnome-mousetrap_0.4-1.dsc
 713571ed79b0ff66b7af6b04e5a8f9f3d4a815d8 1501914 gnome-mousetrap_0.4.orig.tar.gz
 9c7b2776184bebf55e04292d46c1ab5361bf89c3 9455 gnome-mousetrap_0.4-1.debian.tar.bz2
 16161f040c8b739c4faf4f6696cec19d214bf7de 1095860 gnome-mousetrap_0.4-1_all.deb
 5f523a029ec4802541d831584d9b65070a65d7683448702d6615288653bc0525 1518 gnome-mousetrap_0.4-1.dsc
 8a72717252d325af2bc45ba7e589a921a6f0f6f143f36d44f0c9eb812d401f4d 1501914 gnome-mousetrap_0.4.orig.tar.gz
 e8c890dd357b00d875328e5ff54890e56fb1e4b08681ae19931dd50b12263c1e 9455 gnome-mousetrap_0.4-1.debian.tar.bz2
 af83f693c366bddf9a729d514eac9cfbb4cc7c1bc470ff0233056dcb11a61b42 1095860 gnome-mousetrap_0.4-1_all.deb
 597bf22e81fc5bd7fbddd8c7ac6bbe1d 1518 gnome extra gnome-mousetrap_0.4-1.dsc
 47e9f98cb3ea173cf767467d6e9af59e 1501914 gnome extra gnome-mousetrap_0.4.orig.tar.gz
 8820581cab163648e8ff892127207ce9 9455 gnome extra gnome-mousetrap_0.4-1.debian.tar.bz2
 fc745563ca79cbbd0a899188c4f1fdfd 1095860 gnome extra gnome-mousetrap_0.4-1_all.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: