[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [BRLTTY] brltty deb update give still a eternal still unresolved problem

Aldo, le Mon 18 Dec 2006 09:40:30 +0100, a écrit :
> Well, after having updated I heard the beep sound of a starting brltty, 
> but it still forget to kill the older one: 

Debian doesn't start a new brltty if it already started one.

> - can't it be a good idea to prevent from starting a new brltty

That's _already_ the case, and it works for me:

Preparing to replace brltty 3.7.2-5 (using .../brltty_3.7.2-5_i386.deb) ...
Unpacking replacement brltty ...
Setting up brltty (3.7.2-5) ...
Starting Braille terminal driver: process already running.

If it doesn't work for you, then there's a bug on your setup and we
can't work it out unless you give more information.

For a start, could you check that /var/run/brltty.pid properly contains
the pid of the currently running brltty?

Mmm, just to make sure: do you start brltty very early?  For instance,
before / is even mounted read and write, so that brltty may not be able
to write /var/run/brltty.pid? (and hence the upgrade script not be able
to find out that there is a brltty daemon running)


Reply to: