[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Centris 650 Debian 10 SID Installation


I'm trying to install "http://cdimage.debian.org/cdimage/ports/2019-05-24/debian-10.0-m68k-NETINST-1.iso" on a Centris 650 (136 MB, 4 GB root partition, 2 GB swap partition).?? My plan was to install and configure everything on the 650 (including replacing systemd with SysV init since systemd doesn't do well on slow, low-memory systems) and then create a filesystem image for my other, even slower, mac68k systems.

After copying the kernel and initrd from CD to disk and booting with Penguin, the installation proceeded, though very slowly; at every re-draw of the screen, I could see each line being re-drawn.?? I tried twice using the stock CD-ROM drive and once using a more modern CD-ROM drive.?? In all three cases, installation of the basic system succeeded after about four hours, then stopped at the "Configure the package manager" menu -- "Your installation CD or DVD has been scanned ... Scan another CD or DVD?".?? I selected "No" and hit return:?? no response, even after several hours.?? Hitting return repeatedly or trying to select "Yes" or "Go Back" also doesn't work, and eventually the arrow keys stop responding (though F1 and F2 still work to move the selection left or right).?? Switching to an alternate console didn't seem to work (or I was doing it wrong; I tried several combinations of ctrl-alt-f1, ctrl-alt-right_arrow, etc.).

After one of the failures, I tried booting into the new system.?? Booting using the kernel from the CD didn't work -- there was a two-minute pause, which ended in a kernel panic after not finding a root filesystem (or any SCSI devices).?? Maybe that kernel only works for installation using the accompanying initrd??? I next booted into the new system using a 5.x kernel, thinking that I could use apt-get to install everything else, but the keyboard map appeared to be wrong, so I couldn't log in at the VGA console.

I next tried booting using a serial console (console=ttyS0,9600n8).?? After the expected slowness of systemd bringing everything up (about eight minutes), I see a login prompt on the VGA screen and on the serial console.?? The keymap on the VGA screen is wrong, but appears to be ok on the serial console; however, attempting to login using root or the regular user account set up during installation fails ("Login incorrect").?? Apparently users and passwords had not been configured yet when the installation hung.

Next I booted back into Debian 3.1 (using the same 5.x kernel) to see whether I could chroot to the new installation, add a new user and reset root's password.?? That worked.

Booting back into the new installation, I'm able to log in as root at the serial console.?? I don't see an installer log (I can send that if someone knows where it is or how to access it from inside the installer that hung).?? The network is up, and apt-get works, but it doesn't find anything, even after adding these two lines to /etc/apt/sources.list:

deb http://ftp.ports.debian.org/debian-ports/ sid main
deb-src http://ftp.ports.debian.org/debian-ports/ sid main

Looking in a normal web browser, packages appear to be available in "http://ftp.ports.debian.org/debian-ports/pool-m68k/main/", but apt-get doesn't appear to see anything.?? Maybe there's a simple error in my sources.list?


Reply to: