[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

patch to allow gnu99 mode on m68k

Package: gcc-4.3
Version: 4.3.1-2
Severity: important
Tags: patch

On m68k, gnu99 mode doesn't work correctly out of the box due to our
woefully outdated glibc (we're currently stuck at 2.5-1). This is because
the inline schematics changed between glibc 2.5 and 2.7, and gcc 4.2 to 4.3.

This patch configures the built in spec file to pass -fgnu89-inline, and thus allowing
proper compilation and linking with the older glibc on m68k. This patch should not be
merged upstream, and it should be removed once a newer glibc is available for our architecture.

--- linux-old.h    2008-07-04 04:02:21.000000000 -0400
+++ linux.h    2008-07-04 05:23:21.000000000 -0400
@@ -37,6 +37,13 @@
+/* on m68k, we always need to use gnu89 inlining because we're
+   still limited to glibc 2.5. This should be removed after
+   a newer glibc is available */
+#undef CC1_SPEC
+#define CC1_SPEC "%{profile:-p} %{std=gnu99:-fgnu89-inline}"
 /* Here are four prefixes that are used by asm_fprintf to
    facilitate customization for alternate assembler syntaxes.
    Machines with no likelihood of an alternate syntax need not

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gcc-4.3 depends on:
ii  binutils            2.18.1~cvs20080103-4 The GNU assembler, linker and bina
ii  cpp-4.3             4.3.1-2              The GNU C preprocessor
ii  gcc-4.3-base        4.3.1-2              The GNU Compiler Collection (base
ii  libc6               2.7-10               GNU C Library: Shared libraries
ii  libgcc1             1:4.3.1-2            GCC support library
ii  libgomp1            4.3.1-2              GCC OpenMP (GOMP) support library

Versions of packages gcc-4.3 recommends:
ii  libc6-dev                     2.7-10     GNU C Library: Development Librari

-- no debconf information

Reply to: