[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Frame buffer on Coldfire (still problems)

On Thu, 24 Jan 2008, James Kimble wrote:
> I'm using an Epson S1D13a video chip tied to a 320x240 LCD panel on a
> system running a Linux 2.6.10 kernel on the MCF5484 Coldfire chip.
> This electrical configuration works with the MQX OS, by the way, so I
> know that things are fine from that standpoint.
> I have a driver for the chip from Epson that I ported from the v2.6.8
> kernel it was intended for to the v2.6.10 that my BSP port is running
> on. The driver loads without errors and the LCD array lights up. So
> far so good. However the simple little application I've put together
> to work with the screen fails on a call to mmap() with perror()
> reporting an "invalid argument". I've worked at this for days and gone
> no where. What the heck could be going wrong? I've checked the memory
> mapping in driver, I've tried allocating different amounts of memory
> with different offsets in the application. The frame buffer device can
> be opened and ioctl() calls retrieve good information but when the
> mmap() function is called it always returns "invalid argument". The
> only argument I'm even supplying is the screen size and I've tried
> variations on that with the same result.

Please try adding debug info to drivers/video/fbmem.c:fb_mmap(), so you
know why it fails.



Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

Reply to: