[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on a Macintosh Quadra 700

On Mon, Apr 24, 2006 at 08:08:13PM +0200, Alex Teclo wrote:
> 2) I'd like to upgrade to a 2.4.x or 2.6.x kernel. One of the reasons
> is I'd like to use ext3 filesystems. But, on the Debian m68k CD,
> there's no 2.4.x or 2.6.x kernel for the Macintosh (but for Amiga and
> Atari, there is). Where can I find a working 2.4.x or 2.6.x kernel for
> my machine ?

There is no (working) 2.4 kernel for mac. If you want to try a 2.6 kernel,
you could grab one from unstable, 2.6.16-9 has just been installed today. If
you can live with a slightly older one (no changes in m68k code), you can
get one here:


You also find a yaird package there, which you probably have to install,
even though the initrd is not used on m68k. There are probably other
packages that you have to install, before the linux-image can be installed,
but it should be doable from sarge. 2.6 is working fine on my Q840, your
Q700 might have different hardware, which could cause trouble. ADB keyboard
has been a problem for a while, but on an 840 it should be working. Please
also see here:


And report success/failure with the linux-images to this list.


Reply to: