[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing an Amiga 3000T

On Sun, Sep 07, 2003 at 01:25:22PM +0200, Jan-Benedict Glaw wrote:

Is the message you sent me privately still relevant? You said you tried the
"experimental" boot-floppies and the kernel-image is too large. However that
kernel-image is identical to the one in the official boot-floppies, how can
it be too large in one install set but work in another? The only thing that
is different in the "experimental" floppies is that I fixed the missing SCSI

> I'm currently trying to install an Amiga 3000 T with Debian. I'm not new
> to Linux nor to Debian, but I'm failing.
> - Woody installer:
> 	- Woody's install kernel (2.2.18 or 2.2.20 IIRC) seems to be a
> 	  *bit* unstable. After the installation started off
> 	  successfully, d(e)bootstrap and their childs may SIGSEGV'ed or
> 	  SIGBUS'ed...

SIGSEGV sounds like a broken FPU/MMU to me, but I'm no expert in that.
> - Potato installer:
> 	- Basically, it finds it's ramdisk ('Found compressed ramdisk at
> 	  block 0', but it halts there. That's tha last line.
> 	  Some time ago, the root image was large (~10MB or the like),
> 	  but I've checked that, it's only ~3MB. I've even tried to make
> 	  it smaller (dropped some of the free space...), but the result
> 	  is still the same.

The rootimage was never 10MB, root.bin had to fit on a (virtual) 1.44MB
floppy. I guess you are talking about base_2.x.tar.gz which contained the
base packages. Obsolete with woody. But how did you make it smaller?

> Well, then I started to play around:
> - Woody's root.bin with kernel-image-2.4.20-amiga kernel:
> 	- Doesn't work at all, because amiboot-5.6 cannot boot that
> 	  kernel. It's too large. I wonder if *anybody* has ever booted
> 	  this image...

I am using it, Amiga2000, 128MB RAM. Unless you happened to get the one
which I built for all subarches (amiga, atari, mac, *vme), that one does not
boot for me either, but that one never made it into the archive. You are
sure you unpacked the kernel-image package? But then I never tried to
install with that kernel.

cts@aahz:~>uname -a
Linux aahz 2.4.20 #2 Sat Jun 21 16:37:51 EDT 2003 m68k unknown
 13:13:43 up 53 days, 13:14,  1 user,  load average: 1.00, 1.01, 1.17

> - Potato install kernel + Woody root.bin
> 	- Oopses some time after I've started to install the base
> 	  system while accessing 0x00000023 (-> seems to reference some
> 	  struct element...)

Shouldn't happen, the woody kernel works fine for me.
> So far, I see no proper way to install an Amiga (even what I reached is
> halfly handmade - I'm installing rescue and drivers by directly calling
> ./install in a affs partition because it didn't like my floppies...).
> Unfortunately, the install kernel doesn't have the ariadne2 driver
> compiled in. If it had, I'd had a try and use nfs-root to do a fully

If it had, the kernel-image would be even bigger (and you said it is too big
to boot for you already?). And if ariadne2 where built in, people wanted the
other nics to be built in, too, and ISDN, and ..., and the kernel-image
would get even bigger. Thats why modules where invented, they are all in
drivers.bin(?), and it definetely works with Aridane2 since I happen to have
one myself and I installed via the net.

> manual installation... Unfortunately, I don't have a ia32 hosted
> m68k-linux toolchain yet... If anybody could build me a *current* 2.4.x
> kernel from m68k CVS with A3000 support (with scsi and fb) plus affs,
> ext2, ramdisk, nfs, nfsroot, loop, that'd maybe help...
> If anybody installed an Amiga 3000 lately, I'm *really* interested on
> how s/he achieved that!!!

> > How much memory (Chip RAM and Fast RAM) do you have?

> 12+2, but not sure:)

12 Chip sounds a little much, 12 Fast sounds a little little, do you have a
swap partition?

It's not easy being green.                                    Kermit the frog

Reply to: