[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems installing Woody from Linux/m68k

Hello everyone,

I tried installing Woody to a new partition from my existing Linux/m68k
installation (home brewn), using debootstrap as described in the
installation guide.
I quickly ran into a problem though: glibc symbol versions.

I have an old glibc version installed (glibc 2.1.3) and apparently
debootstrap requires at least version 2.3:

bash-2.03# debootstrap --arch m68k woody /mnt/debinst http://ftp.belnet.be/debian
I: Retrieving http://ftp.belnet.be/debian/dists/woody/Release
I: Validating /mnt/debinst/var/lib/apt/lists/debootstrap.invalid_dists_woody_Release
I: Retrieving http://ftp.belnet.be/debian/dists/woody/main/binary-m68k/Packages.gz
I: Validating /mnt/debinst/var/lib/apt/lists/debootstrap.invalid_dists_woody_main_binary-m68k_Packages.gz
/usr/lib/debootstrap/pkgdetails: /lib/libc.so.6: version `GLIBC_2.3' not found (required by /usr/lib/debootstrap/pkgdetails)

Isn't it possible to build debootstrap using an older glibc version? Now
I'm forced to use a different installation method...

I installed debootstrap_0.1.17.17_m68k.deb by the way.

Kind regards,


Reply to: