[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't get networking to work.....

Hi all,
    I am making some headway on getting my network to work, but need more help.
    I have a simple configuration, with a DSL modem hooked to an SMC router, which my machines hang off of. I had my Mac and My PC running on this setup for quite sometime working well until I started installing Debian on my Mac....
    My little home networking runs DHCP.
    Although the debian install program was able to load a network configuration via DHCP just fine and download the whole set of install files, now when I boot into the actual system, it just wouldn't configure me a network. It acted as if I didn't have one. In fact, when it boots there is a line that says: eth0: m68k (Mace), (and then my hardware address)  but then on the next line it says "Looking for built in networking (SONIC)... none."
    So I am booted and eth0 is unconfigured.
    Since I couldn't get it to use DHCP automatically, I tried setting my router to see that hardware address and assign it a fixed address. Now, when I manually give the 'ifconfig eth0 <address>' command it'll start to use that address, so it can ping the router or my PC, but still can't get it to see the net. I've tried putting my dns addresses into /etc/resolv.conf, and tried editing the dhclient-script and dhclient.conf files, but they don't seem to have any effect when I reboot.
    1) Why can't i just run a dhcp command and have it get everything from my router?
     2) failing that, how can I tell it all the info it would have gotten via DHCP, but have it happen everytime on boot??
Thanks much for any help....

Reply to: