[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: still problems with kernel compiling

On 04 Aug 2001 11:05:45 +0200, Nicolas Vilz 'niv' wrote:
> No, I haven't given up yet..
> and no matter which kernel i use (2.4.5, 2.4.6 or 2.4.7) I get almost the
> same Error-Message:
> config.c: In function `config_mac':
> config.c:232: `SYSRQ_KEY' undeclared (first use in this function)
> config.c:232: (Each undeclared identifier is reported only once
> config.c:232: for each function it appears in.)
> make[2]: *** [config.o] Error 1
> make[2]: Leaving directory `/mnt/nivz-90-gig-pladde.de/erste-partition/linux/arch/m68k/mac'
> make[1]: *** [first_rule] Error 2
> make[1]: Leaving directory `/mnt/nivz-90-gig-pladde.de/erste-partition/linux/arch/m68k/mac'
> make: *** [_dir_arch/m68k/mac] Error 2
> mh... and it doesn't matter if I disable Kernel-Hacking... same error-message..
> Could you please help me?
> Nicolas 

You will need to get the source for Linux for m68k Macintosh from CVS on
SourceForge (see http://sourceforge.net/cvs/?group_id=11666 for
instructions).  It's currently at 2.4.1 release.  You will then need to
merge the updates and fix problems (most of the network and scsi drivers
will be broken because of changes in header files) until you get a
usable 2.4.5, 2.4.6 or 2.4.7 release.  

Or you could just wait for one or more of the Linux for m68k Macintosh
hackers to find time in there schedule to do this.

Ray Knight

Reply to: