[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Potato boot floppies on Mac getting "invalid compressed format"

Download the new stuffit 5.5 from www.aladdinsys.com. As I said before, it unzips tgz files no problem. Christian and Michael (must be Linux developers) say the macinstall.tgz and the base2_2.tgz files have no problems with binary downloading that the .bin files have. These are the only 2 files you need to get started. My 68LC040 installs fine on the first phase. It's just that after it reboots the second time, it falls into a program loop when it starts some "internet superserver: inetd" program.
Maybe you'll have better luck than I since you have an FPU built in--I don't. Whatever boot floppies I'm using, they work. Should work for you. I just make a debian directory on the boot drive, copy both tgz files mentioned above in this directory. Drag the macinstall.tgz file onto the stuffit Icon I conveniently placed on the desktop, drag the newly created hqx files from the mac directory created automatically by Stuffit. And I'm ready to set up Potato to get started. I've only tried it about 15 times. Aieeeee
Where have I seen that message before?
Anyway, I double click on the Penguin-18. Click on the file menu and pick settings. I set the kernel and ram disk files to their proper locations, which I have in the mac directory. I don't use the rescue.bin in the images-1.44 folder. I use the smaller one in the mac folder. Seems to be some discrepancy in the install texts. They were still using the names rescue1440 xxx1440 etc.Now they just have rescue.bin driver.bin. Anyway I don't think it makes a difference which bin file you use.
One more thing I had to do to make it work. In the settings from the file menu on the Options tab, I had to manually enter the following line in the Command Line box: root=/dev/ram. I received a reply from the lists that the other stuff from penguin-17 wasn't necessary anymore; i.e. mac5380=4,2 etc. I think Christian said that. At the end of the first phase where it asks you to create a boot floppy, make the disk bootable, or reboot the system, the first two options are not available for m68k macs. I tried them both and received that message.
So I rebooted the system back into System 7.5.5, changed the command line option to root=/dev/sda3, saved the settings, set them as default, and booted right into  the second phase before it abended after reaching this point:
starting internet superserver: inetd
INIT: Id "1" respawning too fast: disable for 5 minutes
That's mine not Linux's
I suspect that the program is trying to set up the modem and printer ports for the internet. But since ttyS1 ...ttyS5 are a undefined on Macs running Linux, the program does not have an escape routine written to take it out of the loop. Or maybe this is BS as Michael would say. I don't know. Hope they fix it. Hope they fix it. Hope they fix it.
----- Original Message -----
From: "Eric Kurnie" <stuff@kurnie.com>
To: <debian-68k@lists.debian.org>
Sent: Sunday, June 25, 2000 2:06 PM
Subject: Fw: Potato boot floppies on Mac getting "invalid compressed format"

> For a little more background, I'm running a Quadra 800 (68040 CPU) with
> 24Megs RAM and have tried with both MacOS 7.5 and 8.1. I downloaded the
> files using Fetch 3.03 and stuffit expander 4.02. In order to reduce
> variables I downloaded everything in the "mac/" directory so stuffit would
> only be used on the three .hqx files. And I also downloaded the
> "macinstall.tgz" to make sure it waasn't a problem with the downloads.   I
> also tried the boot floppies from
http://www.debian.org/~cts/debian-m68k/boot-floppies/ using Netscape 3.01,
> which gave me the same results. I have two SCSI drives attached one 1.8G
> Quantum and the other the original 230M Quantum drive. Everything else is
> standard Mac.
> I could probably get custom kernels or use Penguin-17 but this won't help
> other mac users who are trying to install Potato for the first time. The
> existing boot-floppies must work for someone or why are they there?
> Thanks,
> -Eric
> ----- Original Message -----
> From: "Chris Baker" <
> To: "Christian T. Steigies" <
> Cc: "Eric Kurnie" <
stuff@kurnie.com>; <debian-68k@lists.debian.org>
> Sent: Sunday, June 25, 2000 10:16 AM
> Subject: Re: Potato boot floppies on Mac getting "invalid compressed format"
> > "Christian T. Steigies" <
cts@debian.org> writes:
> >
> > > On Sat, Jun 24, 2000 at 11:15:29PM -0700, Eric Kurnie wrote:
> > > > After searching the archives I found someone else that encountered the
> same problem, but nobody followed up with a solution, so I thought I'd ask:
> > > >
> > > > I tried both the "macinstall.tgz" from
ftp://ftp.debian.org/pub/debian/dists/potato/main/disks-m68k/current/ and
> also the 'mac' directory from the same place. In both cases whenever I try
> running Penguin-18 with the "linux" kernel supplied I get the following
> message:
> > > >
> > > >      GUnzipping Root:install:mac:linux
> > > >      .
> > > >      invalid compressed format (err=2)
> > > >      Error:
> > > >      Unable to read exec header from kernel file (sread error)
> > > Hmm, when I try to boot my amiga with this kernel image, I get:
> > > Compressed image too large! Aborting.
> > >
> > > Is this equivalent to your error code?
> > >
> > > Seems we have a problem, Michael?
> > >
> > > I only wonder what all the mac people who tested the install did. Did
> you
> > > all use a different kernel image? Maybe somebody can build a working
> kernel
> >
> > Nope.  I used bf-mac_2.2.11_m68k.tar.gz from
> >
> >
> >
> > and the given kernel worked fine (I did have to use a previous verion
> > of penguin, but that's another story...).  If you like, I can send you
> > all or part of the archive.
> >
> > Best wishes,
> >
> > cbb
> >
> -- 
> To UNSUBSCRIBE, email to
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: