[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ok, why won't x work

On Mon, 26 Jul 1999, douglas patton wrote:

> I'm at my wits end, and it's the short end.
> I've installed Debian for 68k mac on my centris 650, it has 49megs of
> ram, and is on a dedicated 1.25 gig external hard drive.  I have
> instaled it from the "official" CD rom set.  All shell stuff seems to
> work, as well as all the shell programs I have tried.  
I guess this is Debian/2.1 aka slink?
> But X won't start. I only get "can't find config file" and "tried (such
> and such) files" 
> The bad news is that the config file is exactly where it said it
> looked!  The config file itself won't run, and the xf86setup is there,
> but won't run either.  
> Do I have to run the "config" or "setup" files through a text editor or
> something? are either of them or both corrupted by someting?
Sigh, this looks like the secret FAQ... my turn this time, michael?
The config file for X is not installed unfortunately, you have to copy it by
hand to /etc/X11. The good news, if you can download xfree86-1_3.3.3.1-10
(from potato) and install it, the config file should be set up correctly, as
well as your mouse. It appeared on the mirrors yesterday or so, if you can,
please check it out. And Id like to hear comments on this list, if you get a
XF86Config (and a correct /dev/mouse) link after installing those packages
or not.

When you say, X wont start, there probably is a message saying: "cite the
complete lines above this when you report a problem" or something like that.
you did not do that, so its complete guesing, if you have an xconfiguration
or window manager configuration problem.

xf86setup is no use on m68k machines, it wont help you. xserver-configure
(run as root) from xfree86-1_3.3.3.1-10 will (the version on the slink CDs
will not, unfortunately).
Window manager: I dont think a window manager problem will make X fail,
AFAIR you can run X even without window manager, but its not much fun ;-)

Problems could be mising config file, missing /dev/mouse, problems with the
kernel, missing fonts (but not the famous PEX font error, everybody gets that,
but its not the cause of an X failure). The first two are hopefully fixed
with the new xfree debs.

I hope this is not too confusing now...

Good luck,

Reply to: