[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ethernet not working on Quadra 700

Clark Martin wrote:
> >What you can try as a last resort is to run '/etc/init.d/network stop;
> >/etc/init.d/network start' a few times. No idea why that would work, but
> >it helped others before you.
> Is that network or netbase.  'network' just has settings files.  'netbase'
> has start and stop as commands.

network, as was reported to me. But I've never had to do this myself so I
can't give you more details.

> >And there's always the option to debug the Sonic driver, of course. Use
> >the source.
> I'm just trying to bring it up for the first time.  I don't want to get
> into debugging the drivers, yet.

ROTFL. The ethernet interface doesn't work for _you_ (it's running rock
stable on the Quadra 800 since early this year. And it runs on several 700
with the trick I  mentioned; it seems to be less reliable on the 700). If
you can't find any magic to make it work, debugging the driver might be
your only choice. 

> I tried a test, I tried to ping another machine that was running a program
> which reports incoming pings.  No response.
> I checked ifconfig and it reports 46 receive packets and 0 transmit
> packets.  It continues to report this even after attempted pings both in
> and out.

The driver is dead and won't see any interrupts. The most common cause for
this is the VBL interrupt checkbox. Another possible cause would be some
other Nubus card with no Linux driver that raises an interrupt somehow and
the pending interrupt blocks any further Nubus interrupts from being
delivered (Apple's smart design). Look at /proc/interrupts to see if any
Nubus interrupt has been logged. 
> I've also tried using an Asante Ethernet card.  The boot up process
> recognizes it but doesn't list a driver.  Anyone know where to get such a
> driver and how to install it.

Use the latest 2.2.6 kernel. If it's not in there it hasn't been written.

Reply to: