[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Buddha Flash support?

On Wed, 6 Jan 1999, Michael Schmitz wrote:

> Christian T. Steigies wrote:
> > (Anybody still got my rejected upload to master? I deleted it yesterday...)
> > With this glibc and with kernel 2.1.131 (or 2.2.0 ;-) Catweasel is supported
> > and you "should" be able to install debian. You might have a little chicken
> I don't see what this libc has to do with Catweasel. My libc6-2.0.7v still
> sits in HOLD. But that's not sufficient, you need to recompile dpkg (yikes) 
  ^^^^ good!
> and a few other things to take advantage of the patch. Note that I can't
> upload
> that glibc to incoming any better than you can :-(
catweasel is only supported in 2.1 kernels (and 2.2 ;-) I think its very
hard to backport it to 2.0.
In 2.1 we have the lchown problem, the syscall behaviour has changed (no
expert, but thats what all this glibc discussion was about)
your libc6 and my new libgc fix this, but unfortunately we have the other
installed, where I forgot the patch.
Now, why does is not work, have you ever tried ln -a foo bar running 2.1
with both foo and bar non existant? It fails (with the unpatched glibc).
I think the same thing happens when you install packages with dpkg, since
there are often lots of symlinks in the packages. You can fix this, when you
first touch every non-existant symlink, but this can be a lot of work for
certain packages, I tried it...

Are you sure we have to recompile dpkg? I thought the lchown patch fixed
this, maybe we need a newer ln, anyway it should be consistent for all
archs, I think that was the problem why the patch was accepted only
> ROTFL. Wouldn't it be nice to have working boot floppies, for starters?
> Let me suggest a deal: you build the new libc, rebuild dpkg, cp, ln (and
> what
> else uses chown on symlinks now), and I build base2_ when you're done?
> Waiting ...
Well, very bad news... I am bitten by the substvars problem, cant build
packages because first they fail right after unpacking (substvars, no such
file) and after "fixing" that they fail short before building the package
with the same error. I dont know it its a bug or a feature, and Im not sure
where it comes from...


Reply to: