[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with the Sonnet QuadDoubler Part 2

I've enclosed below the info given when all of the debugging info boxes 
are checked in the Penguin booter prefs.  I've tried booting with the 
cache turned off via the 040 cache control panel, though machine 
operation with the cache disabled was considerably slower (especially 
booting).  Both ways yielded the same results.

Using 'Debian/68k:Penguin Prefs' settings.

Logical To Physical Mapping table (V2)
Logical -> physical : length
0x00000000 -> 0x00000000 : 0x03400000

System: 8.1.0
Gestalt ID: 60 (Mac Centris | Quadra 660av)
CPU: 68040
FPU: 68040 built-in
Physical RAM: 52 MB
Command line is 'root=/dev/ram video=font:VGA8x16'
Decompressing Debian/68k:LINUX
Kernel format: ELF

The kernel will be located at physical 0x00001000
Kernel at logical address 0x2a5f9b0
Decompressing Debian/68k:LINUX
Read 814875 bytes for segment 0, requested 814875
Read 83396 bytes for segment 1, requested 83396

Bootstrap's bootinfo version: 2.0
Kernel's bootinfo version	: 1.0
Kernel entry physical is 0x2000
RAM disk at 0x02b684b4, ends at 0x02c008b4, size is 609 K
Kernel segment 0 at 0x2a5f9b0, size 814875
Kernel segment 1 at 0x2b288d0, size 256993
Kernel size is 0x107b01

boot_info is at 0x2b674b1
boot_info size is 0x610

ramdisk logical target 0x3367c00
ramdisk physical at 0x3367c00
ramdisk physical top at 0x3400000

Bootstrap logical 1: 0x00000000
Bootstrap physical : 0x00000000

Dump of bootinfo, version 1.0:
bi.machtype            = 0x3
bi.cputype             = 0x84
bi.memory[0].addr      = 0x00000000
bi.memory[0].size      = 0x03400000
bi.num_memory          = 0x1
bi.ramdisk_size        = 0x00000261
bi.ramdisk_addr        = 0x03367c00
bi.command_line        = root=/dev/ram video=font:VGA8x16
bi.bi_mac.videoaddr    = 0x50100700
bi.bi_mac.videorow     = 0x340
bi.bi_mac.videodepth   = 0x8
bi.bi_mac.dimensions   = 0x02700340
bi.bi_mac.args         = 0x0
bi.bi_mac.boottime     = 0x361d48f6
bi.bi_mac.gmtbias      = 0xfffffe98
bi.bi_mac.bootver      = 0x6c
bi.bi_mac.videological = 0x50100700
bi.bi_mac.scc          = 0x50f04000
bi.bi_mac.id           = 0x3c
bi.bi_mac.memsize      = 0x34
bi.bi_mac.serialmf     = 0x0
bi.bi_mac.serialhsk    = 0x2580
bi.bi_mac.serialgpi    = 0x2580
bi.bi_mac.printf       = 0x0
bi.bi_mac.printhsk     = 0x2580
bi.bi_mac.printgpi     = 0x2580
bi.bi_mac.cpuid        = 0x2
bi.bi_mac.rombase      = 0x40800000
bi.bi_mac.adbdelay     = 0x30e
bi.bi_mac.timedbra     = 0x30e0

Booting Linux (fasten seat belts, please)...

The following is the message I got when trying to boot debian, starting 
from the line where the 040 access error occurred.  As far as I could 
tell, there was no message indicating a kernel panic.

68040 access error, ssw=a5
*** BUS ERROR ***  FORMAT = 7
Current Process id is 1
PC: 000aa146
SR: 2000    SP: 033faec4
d0: 00000017  d1: 00008000  d2: 00004074  d3: 00000004
d4: 00000007  d5: 000de056  a0: 033f4018  a1: 00115f44
Process swapper (pid: 1, stackpage = 033fa000)
Frame format = 7  eff  addr=0000008a  ssw=00a5  faddr=50f10060
wb 1 stat/addr/data: 00a5  50f100b0  0a000000
wb 2 stat/addr/data: 0025  50f100b0  0000000a
wb 3 stat/addr/data: 0025  50f100b0  0000000a
push data: 0a000000  000dfb43  000dff40  033faf4c
Stack from 033faf28:  (followed by too many numbers for me to write)

The above error ocurred whether I was booting from a copy on the hard 
drive or from a disk image.

Also, I tried booting linux from the regular (non-debian) distribution.  
I received the message "Kernel Panic: VFS: Unable to open root FS".

My machine configuration is as follows:
Quadra 660AV with Sonnet QuadDoubler 100/50MHz accelerator
Mac OS 8.1
250 MB hard drive
Iomega Zip drive
Iomega Jaz drive (which I hope to use as the root directory, once I get 
it formatted)
Supra FaxModem 33.6
Stylewriter 1200

If this is still not enough info for someone to help me with my problem, 
please notify me.

Thank you all in advance!


Reply to: