[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Issues brining BD disks from the command line - write failures

First off I want to say thank all of you that work on this software that makes it possible to do this stuff.
I'm more impressed than you can imagine.

Now that I have hopefully 'buttered you up' a little bit, I'm in need of assistance, and I have exhausted my google skills in an attempt to find an answer to the issue. At this point I'm trying trial and error, and at $1.25 a disc, it's getting expensive.

A (large) part of my issue is me; I had this working at one point, didn't write down _exactly_ all the requirements and process I followed, and there have been quite a few kernel and program updates since it worked.

I am trying to backup large .wav files ( 1.3 - 2+GB in size) to BD-R media.

When I had it working, I would create a 25GB file with truncate, use mkudffs to format the file as a filesystem, loopback mount it, and copy data over to the file system, sync a couple of times, dismount and the use cdrecord or growisofs (I have tried both) to burn the image to the media.

I have two burners, on two different systems, so I know I'm pretty sure I'm not having a hardware issue.

One is attached via a SAS controller via an eSATA breakout cable to an external eSATA enclosure:
 description: SCSI CD-ROM
                         product: BD-RE  WH14NS40
                         vendor: HL-DT-ST
                         physical id: 0.0.0
                         bus info: scsi@4:0.0.0
                         logical name: /dev/cdrom1
                         logical name: /dev/cdrw1
                         logical name: /dev/dvd1
                         logical name: /dev/dvdrw1
                         logical name: /dev/sr1
                         version: 1.00
                         capabilities: removable audio
                         configuration: status=ready
                            physical id: 0
                            logical name: /dev/cdrom1

The other burner is connected via internal onboard SATA controller:
             description: DVD-RAM writer
             product: BD-RE  BH08LS20
             vendor: HL-DT-ST
             physical id: 0.1.0
             bus info: scsi@2:0.1.0
             logical name: /dev/cdrom1
             logical name: /dev/cdrw1
             logical name: /dev/dvd1
             logical name: /dev/dvdrw1
             logical name: /dev/sr0
             version: 1.00
             capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
             configuration: ansiversion=5 status=nodisc

I'm now _way_ behind on moving this stuff off to removable media and I'm starting to get a bit desperate.

This last attempt, on the external burner using growisofs, new server and fresh OS load is finally prompted me to annoy you with a plea for help. This is as far as it got that time:

growisofs -speed=1 -Z /dev/sr1=/mnt/md9/bdburn/BDBurn.udf
Executing 'builtin_dd if=/mnt/md9/bdburn/BDBurn.udf of=/dev/sr1 obs=32k seek=0'
/dev/sr1: pre-formatting blank BD-R for 24.8GB...
/dev/sr1: "Current Write Speed" is 2.0x4390KBps.
949059584/25000000000 ( 3.8%) @0.3x, remaining 216:40 RBU 100.0% UBU 29.2% 951975936/25000000000 ( 3.8%) @0.2x, remaining 217:40 RBU 100.0% UBU 20.8% 954499072/25000000000 ( 3.8%) @0.2x, remaining 218:19 RBU 100.0% UBU 12.5%
WRITE@LBA=720a0h failed with SK=3h/WRITE ERROR]: Input/output error
write failed: Input/output error
/dev/sr1: flushing cache
/dev/sr1: closing track
/dev/sr1: closing session
CLOSE SESSION failed with SK=5h/INVALID FIELD IN CDB]: Input/output error
/dev/sr1: reloading tray

Am I creating too large of a file to burn to the media - I note that growisofs is saying "preformatting to 24.8 GB"?
This is the size I have used int he past that worked.

This is my actual UDF file size.

ls -al /mnt/md9/bdburn/BDBurn.udf
-rw-r--r-- 1 root root 25000000000 May  6 17:39 /mnt/md9/bdburn/BDBurn.udf

_any_ help in getting this sorted will be greatly appreciated.

Reply to: