[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cdrecord floating point exception

>From zoubidoo@hotmail.com Fri Jan 30 21:07:19 2009

>Joerg, Thanks for the explanation - it's all a bit over my head; I'm just using what came with my distribution.
>I have downloaded your cdrtools, built and tried again.  Here is the result (still no success).  Does this help?

> ./cdrecord -v -dao speed=1 dev=/dev/dvd ~/newworld.iso 
>Cdrecord-ProDVD-ProBD-Clone 2.01.01a57 (i686-pc-linux-gnu) Copyright (C) 1995-2009 J???rg Schilling
>TOC Type: 1 = CD-ROM
>./cdrecord: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
>./cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
>./cdrecord: WARNING: This causes a high risk for buffer underruns.
>./cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler.
>./cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
>./cdrecord: WARNING: This causes a high risk for buffer underruns.

You did not install cdrecord correctly as you see from this messages.
Cdrecord needs to be installed suid root in order to be able to open all needed 
devices and in order to send all needed SCSI commands.

>scsidev: '/dev/dvd'
>devname: '/dev/dvd'
>scsibus: -2 target: -2 lun: -2
>Warning: Open by 'devname' is unintentional and not supported.

Your dev= parameter was invalid.

If you only have one drive, just omit the dev= parameter.
If you have more than drive, call cdrecord -scanbus to find the right dev= 

>Linux sg driver version: 3.5.27
>Using libscg version 'schily-0.9'.
>SCSI buffer size: 64512
>atapi: 1
>Device type    : Removable CD-ROM
>Version        : 5			<--- Cable problems or Firmware bug?
>Response Format: 2
>Capabilities   : 
>Vendor_info    : 'GIGABYTE'
>Identifikation : 'GO-W1608A       '
>Revision       : 'B8S2'
>Device seems to be: Generic mmc2 DVD-R/DVD-RW/DVD-RAM.
>Current: DVD+RW
>Profile: DVD+R/DL 
>Profile: DVD+R 
>Profile: DVD+RW (current)
>Profile: DVD-RW sequential recording 
>Profile: DVD-RW restricted overwrite 
>Profile: DVD-R sequential recording 
>Profile: DVD-ROM 
>Profile: CD-RW 
>Profile: CD-R 
>Profile: CD-ROM 
>Using generic SCSI-3/mmc-3 DVD+RW driver (mmc_dvdplusrw).
>Supported modes: PACKET SAO
>Drive buf size : 1602048 = 1564 KB
>./cdrecord: Warning: The DMA speed test has been skipped.

Did you enable DMA for the drive?

>FIFO size      : 4194304 = 4096 KB
>Track 01: data  4391 MB        
>Total size:     4391 MB = 2248251 sectors
>Current Secsize: 2048
>WARNING: Drive returns illegal Disk type CD-DA or CD-ROM.

>    Capacity  Blklen/Sparesz.  Format-type  Type
>     2295104             2048         0x00  Unformated or Blank Media
>     2295104                0         0x26  Reserved (0)
>Format was needed.
>Starting to write CD/DVD/BD at speed 1 in real FORMAT mode for single session.
>Last chance to quit, starting real write    0 seconds. Operation starts.
>Formatting media
>Formatting time:   92.518s

Auto-formatting was successful.

>Trying to clear drive status.

This may be from a drive firmware bug or frim running hald (hald is 

Try to kill hald and retry cdrecord after correctly installing it suid root.


 EMail:joerg@schily.isdn.cs.tu-berlin.de (home) Jörg Schilling D-13353 Berlin
       js@cs.tu-berlin.de                (uni)  
       joerg.schilling@fokus.fraunhofer.de (work) Blog: http://schily.blogspot.com/
 URL:  http://cdrecord.berlios.de/private/ ftp://ftp.berlios.de/pub/schily

Reply to: