[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

BD-R formatting help

I'm monkeying around with the blu-ray drives again (though now it is a
SATA interface) and I've come upon something that I don't quite

I am trying to make the spare area of a BD-R be something larger than
the default.  I was hoping to run something like:

./dvd+rw-format -ssa=4G /dev/dvd

But when I execute this command, it says that it is invalid for the
detected media.  Looking at the code is appears as if this should be a
valid option, I also tried to use:

./dvd+rw-format -force -ssa=4G /dev/dvd

also to no avail.

I took a wild swing at this one.  And thought that maybe this would
fix the problem.

   if (((mmc_profile == 0x1A || mmc_profile == 0x2A) && blank)
       || (mmc_profile != 0x1A && compat)
       || (mmc_profile != 0x12 && mmc_profile != 0x43 &&mmc_profile !=
0x41 && ssa) )
   {   fprintf (stderr,"- illegal command-line option for this media.\n");
       goto offer_options;

After making the above change, it then gets past this portion of the
code and gets down to where the actual formatting is going to take

I get this message:

sr0: CDROM (ioctl) error, command: Test Unit Ready 00 00 00 00 00
Deferred sr00:00: sense key Medium Error
Additional sense indicates Format command failed

And if I eject the disc and re-insert it, then run mediainfo on it, it
shows up as blank.  If I run mediainfo on it before I eject it, I get
a bunch of garbage.

Any thoughts?

Thank you,
Matt Schulte

Reply to: