[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No supported write modes with LG GSA-H62N SATA DVD+RW


> I have a pioneer 212 (sata) DVD
> running Fedora 7
> Neither cdrecord nor growisofs work
> WIN XP works, but only if DMA is disabled for the drive
> Both machines have a VIA VT6420
> I tried my burner on a friends machine with nvidia sata
> controller and everything worked fine.

This matches well the image which emerges
for this issue.
Trouble maker is the VT6420 with Linux,
not the drives, not the burner software.

> 00000000  2a 00 00 00 00 00 00 00  10 00
> 00008000  2a 00 00 00 00 10 00 00  10 00
> 00010000  2a 00 00 00 00 20 00 00  10 00

Arghh ! These are SCSI commands 2Ah WRITE 10
which send 16 blocks = 32 KB of data to LBA
addresses 0, 16, 32.
Something (the controller ?) did put copies of the
commands at the head of the data payload.

This would explain why we get parameter
length errors with mode page 05h.
The drive really receives too many bytes.

> The 32 bytes of data at the end were lost.

The write command announced 32 KiB. So what is
surplus at the beginning of the payload will
get truncated at the end ... somehow.
(I wonder why this happened quite gracefully
and did not get everything stuck, though.)

Thanks for this report. It confirms the suspicion
against the VT6420 controller and it even gives
an idea what is actually going wrong.

> It looks like I will need to get a PATA burner!

Or you get that "VIA SATA PCI controller (VT6421)"
which brought the remedy for Andreas Klauer in July.

Have a nice day :)


Reply to: