[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: growisofs -Z /dev/dvd=image.iso



Hi,

> I tried 
> 
> growisofs -dvd-compat -Z /dev/dvd=image.iso
> 
> on Linux and it worked.
> I tried the same on FreeBSD, NetBSD and OpenBSD and I got
> 
> growisofs: no mkisofs options are permitted with =, aborting...
> 
> Why the difference?

My own software is using growisofs in a similar way. So i am
interested in learning about your troubles (before my users do).

The message "no mkisofs options are permitted with ="
is issued in  growisofs.c  and triggered by
  ((mkisofs_argc-growisofs_argc)>1)

With my Linux system and your command line, those variables
got as values :
  mkisofs_argc= 1
  growisofs_argc= 0
so the difference is 1 and the message is not issued.


Obviously, your BSD runs produce other values.
It would be interesting to see those values and
the content of array 
  mkisofs_argv
from index 0 to index mkisofs_argc-1 .

I looked up in growisofs.c (version 5.21) the text
  "no mkisofs options are permitted with ="
and added some lines above, before line 
  if (imgfd<0)
the lines
  { int i;
    fprintf (stderr,"mkisofs_argc= %d  growisofs_argc= %d\n",
                    mkisofs_argc,growisofs_argc);
    for(i=0;i<mkisofs_argc;i++) 
      fprintf(stderr,"mkisofs_argv[%d]= '%s'\n",i,mkisofs_argv[i]);
  }

After recompiling and installing, the program now reports
  mkisofs_argc= 1  growisofs_argc= 0
  mkisofs_argv[0]= 'mkisofs'


If you feel able to do this little code change, then please
report the outcome on your BSD systems.


Have a nice day :)

Thomas



Reply to: