[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linux kernel error reading end of cd/dvd

On Wed 8 October 2003 13:03, Rob Bogus wrote:
> Well, it could be a bad CD ;-) I just tried using dd on my old
> burner (real SCSI), my recent burner (ATAPI+ide-scsi), and the
> 52x reader only (ATAPI+ide-cd) and a Redhat 2.4.18-24.8.0 kernel,
> and no error on any of them. I can't try a 2.6 kernel without
> rebooting, but I'll try that at work.

I'm running a standard 2.4.21 kernel.org kernel. My original 
experiment was with my LG DVD-ROM (ATAPI+ide-cd). I tried the same 
CD in my burner (LiteOn, ATAPI+ide-scsi) and it gives the same 
error. I've also tried a different CD, with 38789, and it reads 
correctly in both, as did another burned CD with 14425 blocks.

I tried mounting the CD that did not work, and copy all files off of 
it. No problems there. Perhaps it's some sort of odd copy 
protection? (it's a Nero install CD that came with my burner, I 
figured I'd paid for it but never used it before so now would be a 
good time :-))

> Could be media, hardware/firmware, or as you say, something we
> don't understand.

Well, I'm not at all sure what it is anymore now. Perhaps it's just 
the quality of CDs that's less than people expect.

> Another thought, with some older cdrecord versions I convinced
> myself that using -pad making the ISO image was more successful
> than using the option in cdrecord. Don't know if that was/is true
> or just based on too few trials. Also seem to remember that
> readcd works differently with the ide-cd driver.

Hmm, I've never used the -pad option either way, can't comment 

> Too many possibilities, and Joerg is not motivated to do anything
> with Linux except whine that the kernel people doing the work
> won't take orders and do it his way.

He doesn't seem to be doing much with cdrecord at all lately.

GPG public key: http://home.student.utwente.nl/l.e.veen/lourens.key

Reply to: