[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Nbd] nbd0: Wrong magic (0x25609513) error

I have been using diskless mythbuntu (based on ltsp) for several years. After upgrading from Ubuntu 11.04 -> 11.10, nbd mounting has stopped working from the front ends.

The nbd version is 2.9.23

The kernel version is 3.0.0

In /var/log/syslog on the server I get the error "nbd0: Wrong magic (0x25609513)".

nbd-server is configured to use inetd using port 2000.

I have also tried stopping inetd and manually running nbd on the local server using the commands
nbd-server -d 2000 /opt/ltsp/images/i386.img
nbd-client localhost 2000 /dev/nbd0

This results in the same error.

I have tried turning on debugflags=0xfff in the nbd kernel module and building nbd-server with additional tracing but am having trouble solving the issue.

grepping the source code 0x25609513 appears to be the correct magic number
#define NBD_REQUEST_MAGIC 0x25609513, so I'm not sure what going on. Perhaps an introduced endianess issue?

It is not clear to me if this is a kernel module issue or a nbd package issue.

If there is any additional information I can supply, please let me know

Reply to: