[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#188407: marked as done (apt: Keep the package lists in /var/lib/apt/lists compressed with gzip)

Your message dated Mon, 12 Jul 2010 10:39:28 +0000
with message-id <E1OYGQ4-0006hZ-7S@franck.debian.org>
and subject line Bug#188407: fixed in apt 0.7.26~exp10
has caused the Debian Bug report #188407,
regarding apt: Keep the package lists in /var/lib/apt/lists compressed with gzip
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

188407: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=188407
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: apt
Version: 0.5.4
Severity: wishlist

Make APT store the downloaded lists gzipped and unzip them on the fly when
loading, cause they take a lot of space on old and small dedicated Debian
systems (routers, firewalls, X terminals, etc).

The complete lists for main, contrib, non-us and non-free currently weigh in
at about 10 megs, while compressing them with gzip -9 brings them down to only
2.5 megs, which is a significant saving on types of systems mentioned above.

One can probably forgo APT on those systems and tweak them by hand, but it
sure is nice to have APT available for occasional upgrades.

The same goes for the /var/lib/dpkg/{status,available} lists of DPKG.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux inspiron 2.4.20-ck3_o1_pe_ll_rl2_tune_radeonfb #1 Fri Mar 28 01:24:58 CET 2003 i686

Versions of packages apt depends on:
ii  libc6                        2.3.1-16    GNU C Library: Shared libraries an
ii  libstdc++2.10-glibc2.2       1:2.95.4-15 The GNU stdc++ library

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: apt
Source-Version: 0.7.26~exp10

We believe that the bug you reported is fixed in the latest version of
apt, which is due to be installed in the Debian FTP archive:

  to main/a/apt/apt-doc_0.7.26~exp10_all.deb
  to main/a/apt/apt-transport-https_0.7.26~exp10_i386.deb
  to main/a/apt/apt-utils_0.7.26~exp10_i386.deb
  to main/a/apt/apt_0.7.26~exp10.dsc
  to main/a/apt/apt_0.7.26~exp10.tar.gz
  to main/a/apt/apt_0.7.26~exp10_i386.deb
  to main/a/apt/libapt-pkg-dev_0.7.26~exp10_i386.deb
  to main/a/apt/libapt-pkg-doc_0.7.26~exp10_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 188407@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Michael Vogt <mvo@debian.org> (supplier of updated apt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 12 Jul 2010 11:41:01 +0200
Source: apt
Binary: apt apt-doc libapt-pkg-dev libapt-pkg-doc apt-utils apt-transport-https
Architecture: source all i386
Version: 0.7.26~exp10
Distribution: experimental
Urgency: low
Maintainer: APT Development Team <deity@lists.debian.org>
Changed-By: Michael Vogt <mvo@debian.org>
 apt        - Advanced front-end for dpkg
 apt-doc    - Documentation for APT
 apt-transport-https - APT https transport
 apt-utils  - APT utility programs
 libapt-pkg-dev - Development files for APT's libapt-pkg and libapt-inst
 libapt-pkg-doc - Documentation for APT development
Closes: 188407 588610
 apt (0.7.26~exp10) experimental; urgency=low
   [ David Kalnischkies ]
   * apt-pkg/contrib/error.{cc,h}:
     - remove constness of va_list parameter to fix build on amd64 and co
       Thanks Eric Valette! (Closes: #588610)
   * apt-pkg/deb/debmetaindex.cc:
     - do not query each architecture for flat file archives
     - fix typo preventing display of architecture in Info()
   * methods/bzip2.cc:
     - add a copycat of the old gzip.cc as we need it for bzip2 and lzma
   [ Martin Pitt ]
   * debian/rules:
     - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
   * apt-pkg/contrib/fileutl.{h,cc}:
     - Add support for reading of gzipped files with the new "ReadOnlyGzip"
       OpenMode. (Closes: #188407)
     - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
     - [ABI BREAK] This adds a new private member to FileFd, but its
       initialization is in the public header file.
   * configure.in:
     - Check for zlib library and headers.
   * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
     apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
     - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
   * apt-pkg/deb/debindexfile.cc:
     - If we do not find uncompressed package/source/translation indexes, look
       for gzip compressed ones.
   * apt-pkg/acquire-item.cc:
     - If the Acquire::GzipIndexes option is true and we download a gzipped
       index file, keep it as it is (and rename to .gz) instead of
       uncompressing it.
   * doc/apt.conf.5.xml:
     - Document the new Acquire::GzipIndexes option.
   * doc/po/apt-doc.pot, doc/po/de.po:
     - German translation of new Acquire::GzipIndexes option.
   * Add test/test-indexes.sh:
     - Test behaviour of index retrieval and usage, in particular with
       uncompressed and gzip compressed indexes.
   * methods/gzip.cc: With FileFd now being able to read gzipped files, there
     is no need for the gzip method any more to spawn an external gzip process.
     Rewrite it to use FileFd directly, which makes the code a lot simpler, and
     also using less memory and overhead.
 410ad37d43a256836d8c634a3c74fe8ad71e381d 1332 apt_0.7.26~exp10.dsc
 f377abbe6c13ee0883831c763fb2edaff960629f 2907354 apt_0.7.26~exp10.tar.gz
 5807819230aa00413d4c855e11dd26383c802e12 228340 apt-doc_0.7.26~exp10_all.deb
 319fc644b37fafeefc89fa533ea090ea1e6fe0a5 645040 libapt-pkg-doc_0.7.26~exp10_all.deb
 4190aeceaf318297370711c8caad179668bd5dbf 2003604 apt_0.7.26~exp10_i386.deb
 5800b0fb5439d3a99802518ef8e9ac6607d31e07 142354 libapt-pkg-dev_0.7.26~exp10_i386.deb
 7e6879e2b9de5f1d7a74ff2665f313c6a758b890 264716 apt-utils_0.7.26~exp10_i386.deb
 b2dfdded9bb0db432d7420ad008dc071059c12ef 78014 apt-transport-https_0.7.26~exp10_i386.deb
 a62fa20cfac393dcb6a142c5e4fa8ee5f156e4781267f24d1a8dbba2f9fd8598 1332 apt_0.7.26~exp10.dsc
 d9675ab9ce4b78b3e7c5e69f215607bb662beb6fae996afe7b06f3283cacb83a 2907354 apt_0.7.26~exp10.tar.gz
 6a6c673127b183e445b979e4e05c1ee7c1d6e2355b860ea6e789abd65aed728d 228340 apt-doc_0.7.26~exp10_all.deb
 f9a6d8279832850e79b150069a2b42b95c7b9124ada93f6c7e535d9a68a2a995 645040 libapt-pkg-doc_0.7.26~exp10_all.deb
 2e6cb5990f296e40ad6f0e34868d4b2685ded0f9ff1a493cce64c8ebc78797a2 2003604 apt_0.7.26~exp10_i386.deb
 41ddbb9494e46501055800fa2fd9110f889ab2869bea20896be03b573b3ad1da 142354 libapt-pkg-dev_0.7.26~exp10_i386.deb
 d4d535f8cee4d2580f96424a61ba964ff25da9877cc7fe4208d1656a0ae1d3b0 264716 apt-utils_0.7.26~exp10_i386.deb
 dd6f747c686d4f4f00ef2b473b4a63e32f3e95e674d4b0e8b8ff0ed91f7e5784 78014 apt-transport-https_0.7.26~exp10_i386.deb
 12f14bfa7ab36f58d68a5441e44ff372 1332 admin important apt_0.7.26~exp10.dsc
 283826d3c4209c9203675d5e43e8ab2a 2907354 admin important apt_0.7.26~exp10.tar.gz
 9cd0f9b8c49513312f327db825748f96 228340 doc optional apt-doc_0.7.26~exp10_all.deb
 54369a112a56b286325212808c5bdf8e 645040 doc optional libapt-pkg-doc_0.7.26~exp10_all.deb
 bdfc05a0eef653e4755ef8f576416105 2003604 admin important apt_0.7.26~exp10_i386.deb
 d28c11c261e2ddbb3b7fe51b2e03e610 142354 libdevel optional libapt-pkg-dev_0.7.26~exp10_i386.deb
 dc8ae40bd69aaae66b099bc69335abdb 264716 admin important apt-utils_0.7.26~exp10_i386.deb
 82d6dd9b2472c7b018e9d6058e0e8eab 78014 admin optional apt-transport-https_0.7.26~exp10_i386.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: