[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#533551: -s does not check signatures

Package: apt
Version: 0.7.21
Severity: wishlist
File: /usr/bin/apt-get


when I run "apt-get -s dist-upgrade" everything is reported fine. But
then when I run "apt-get dist-upgrade" I get:

WARNING: The following packages cannot be authenticated!
  ia32-libs ia32-libs-gtk
Install these packages without verification [y/N]? 

This should already show up when running with -s.


-- Package-specific info:

-- (/etc/apt/preferences present, but not submitted) --

-- (/etc/apt/sources.list present, but not submitted) --

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable-i386
  APT policy: (500, 'unstable-i386'), (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux
Locale: LANG=C, LC_CTYPE=de_DE (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages apt depends on:
ii  debian-archive-keyring        2009.01.31 GnuPG archive keys of the Debian a
ii  libc6                         2.9-12     GNU C Library: Shared libraries
ii  libgcc1                       1:4.4.0-4  GCC support library
ii  libstdc++6                    4.4.0-4    The GNU Standard C++ Library v3

apt recommends no packages.

Versions of packages apt suggests:
ii  apt-doc                   0.7.21         Documentation for APT
ii  aptitude         terminal-based package manager
ii  bzip2                     1.0.5-1        high-quality block-sorting file co
ii  dpkg-dev                  1.14.26        Debian package development tools
ii  lzma                      4.43-14        Compression method of 7z format in
ii  python-apt          Python interface to libapt-pkg

-- no debconf information

Reply to: