[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#286061: marked as done (manpage for apt-cache conflicts with internal help for pkgnames)

Your message dated Mon, 24 Nov 2008 11:32:06 +0000
with message-id <E1L4Zfi-0000SZ-Iy@ries.debian.org>
and subject line Bug#286061: fixed in apt 0.7.19
has caused the Debian Bug report #286061,
regarding manpage for apt-cache conflicts with internal help for pkgnames
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

286061: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=286061
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: apt
Version: 0.5.27
Severity: normal

The internal help for apt-cache states:

   pkgnames - List the names of all packages

The manpage for apt-cache states:

   pkgnames [ prefix ]
          This  command prints the name of each package in the system. The
          optional argument is a prefix match to filter the name list. The
          output  is suitable for use in a shell tab complete function and
          the output is generated extremely quickly. This command is  best
          used with the --generate option.

The phrasing "in the system" is not at all obvious to mean "any package
apt knows about". It's far more likely to indicate the same basic list
that "dpkg -l" would give.

-- Package-specific info:

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.7

Versions of packages apt depends on:
ii  libc6                       2.3.2.ds1-16 GNU C Library: Shared libraries an
ii  libgcc1                     1:3.4.1-7    GCC support library
ii  libstdc++5                  1:3.3.4-9    The GNU Standard C++ Library v3

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: apt
Source-Version: 0.7.19

We believe that the bug you reported is fixed in the latest version of
apt, which is due to be installed in the Debian FTP archive:

  to pool/main/a/apt/apt-doc_0.7.19_all.deb
  to pool/main/a/apt/apt-transport-https_0.7.19_i386.deb
  to pool/main/a/apt/apt-utils_0.7.19_i386.deb
  to pool/main/a/apt/apt_0.7.19.dsc
  to pool/main/a/apt/apt_0.7.19.tar.gz
  to pool/main/a/apt/apt_0.7.19_i386.deb
  to pool/main/a/apt/libapt-pkg-dev_0.7.19_i386.deb
  to pool/main/a/apt/libapt-pkg-doc_0.7.19_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 286061@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Michael Vogt <mvo@debian.org> (supplier of updated apt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 24 Nov 2008 10:33:54 +0100
Source: apt
Binary: apt apt-doc libapt-pkg-dev libapt-pkg-doc apt-utils apt-transport-https
Architecture: source all i386
Version: 0.7.19
Distribution: unstable
Urgency: low
Maintainer: APT Development Team <deity@lists.debian.org>
Changed-By: Michael Vogt <mvo@debian.org>
 apt        - Advanced front-end for dpkg
 apt-doc    - Documentation for APT
 apt-transport-https - APT https transport
 apt-utils  - APT utility programs
 libapt-pkg-dev - Development files for APT's libapt-pkg and libapt-inst
 libapt-pkg-doc - Documentation for APT development
Closes: 286061 349038 419521 426913 463030 505476 505483 505491 505495 505506 505513 505518 505539 505569 505614 505683 505727 505757 505762 505902 505909 505934 505949 506085 506452 506545
 apt (0.7.19) unstable; urgency=low
   [ Eugene V. Lyubimkin ]
   * doc/sources.list.5.xml:
     - Mentioned allowed characters in file names in /etc/apt/sources.list.d.
       Thanks to Matthias Urlichs. (Closes: #426913)
   * doc/apt-get.8.xml:
     - Explicitly say that 'dist-upgrade' command may remove packages.
     - Included '-v'/'--version' as a command to synopsis.
   * cmdline/apt-cache.cc:
     - Advanced built-in help. Patch by Andre Felipe Machado. (Closes: #286061)
     - Fixed typo 'GraphVis' -> 'GraphViz'. (Closes: #349038)
     - Removed asking to file a release-critical bug against a package if there
       is a request to install only one package and it is not installable.
       (Closes: #419521)
   [ Michael Vogt ]
     - fix SIGHUP handling (closes: #463030)
   [ Christian Perrier ]
   * Translations:
     - French updated
     - Bulgarian updated. Closes: #505476
     - Slovak updated. Closes: #505483
     - Swedish updated. Closes: #505491
     - Japanese updated. Closes: #505495
     - Korean updated. Closes: #505506
     - Catalan updated. Closes: #505513
     - British English updated. Closes: #505539
     - Italian updated. Closes: #505518, #505683
     - Polish updated. Closes: #505569
     - German updated. Closes: #505614
     - Spanish updated. Closes: #505757
     - Romanian updated. Closes: #505762
     - Simplified Chinese updated. Closes: #505727
     - Portuguese updated. Closes: #505902
     - Czech updated. Closes: #505909
     - Norwegian Bokmål updated. Closes: #505934
     - Brazilian Portuguese updated. Closes: #505949
     - Basque updated. Closes: #506085
     - Russian updated. Closes: #506452
     - Marathi updated.
     - Ukrainian updated. Closes: #506545
 7e398a5b11c000f89792c40c6d13df3991cabc24 1212 apt_0.7.19.dsc
 d30d02f594ec75df4b2a3883f1464fc28d833868 2038700 apt_0.7.19.tar.gz
 d078be1164d459eaa818d4f80b3e214af1549207 101324 apt-doc_0.7.19_all.deb
 b80010c4148bf3f641c83c2e19e7dedac56c44fc 125468 libapt-pkg-doc_0.7.19_all.deb
 745dfc34b3681364964979cb79b8e13d6721c669 1640238 apt_0.7.19_i386.deb
 83058fe2d9e3c1d5ea595408f80a2c687e98db22 110046 libapt-pkg-dev_0.7.19_i386.deb
 2d0b0f06bb61a0d5d022629e79cb452e9c84de24 189270 apt-utils_0.7.19_i386.deb
 1549db1e55c284f2857a08a3a25099c16810516e 59616 apt-transport-https_0.7.19_i386.deb
 43ec6692a2febfc409ec2f42cc147a390fc8696a5b99c2e189f4bc9a250f483f 1212 apt_0.7.19.dsc
 c928f5eb2baffb50e7ccf02d07a16daf867945c8aa542d500bbbbaff7bbcef42 2038700 apt_0.7.19.tar.gz
 0cf3a0fb7a0f1567368b9a66e8a008a5a328d884205087650562725febd67ed3 101324 apt-doc_0.7.19_all.deb
 3725034445988d56853606d6f9488357bbc95464fa33537aaa6cd692f5aafd46 125468 libapt-pkg-doc_0.7.19_all.deb
 238f24b4028d1752c14dca1da03b49807e4732b4680533be46f8f4c396975b5c 1640238 apt_0.7.19_i386.deb
 02b2d4368b1e725c9a2078f1130e58e635bb5b9fb71cdf67af95e947a803bf72 110046 libapt-pkg-dev_0.7.19_i386.deb
 efb66d0464310ff6281909363b0f6ca0f46cf176058232eba9483d2b4df4d011 189270 apt-utils_0.7.19_i386.deb
 a012650038e920ce3fed11358d8a3cfd2922d5c6b07499ccfcc5da19efa4dff8 59616 apt-transport-https_0.7.19_i386.deb
 8f1b920cebde0d438458cbd7effaa959 1212 admin important apt_0.7.19.dsc
 0ef50176aea36cb0cce633a9b62dc7eb 2038700 admin important apt_0.7.19.tar.gz
 78775957fa9a888c95aeb80c3dd1d22e 101324 doc optional apt-doc_0.7.19_all.deb
 b19f0d988436b648cc752934e0eb6f6e 125468 doc optional libapt-pkg-doc_0.7.19_all.deb
 5ea569ba4886233acc549b422e937380 1640238 admin important apt_0.7.19_i386.deb
 0916faa8c2b55fd709a8325d246ae88e 110046 libdevel optional libapt-pkg-dev_0.7.19_i386.deb
 58bcfd95d572dc5276125ea1a36f2921 189270 admin important apt-utils_0.7.19_i386.deb
 ae3ebfc3394013e9bcc0048eb0791f51 59616 admin optional apt-transport-https_0.7.19_i386.deb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: