[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#381133: apt: Does not support digest http authentication

Package: apt
Severity: normal

When /etc/apt/sources.list line has an URL in this format:


'apt-get update' will have a "401 Authentication Required" error when the 
webserver is configured for Digest Authentication instead of Basic 

Digest Authentication support would be nice to avoid having to send 
passwords in plain text (although an attacker familiar with HTTP headers 
could still use the digest info to log into the server).



-- System Information:
Debian Release: testing/unstable
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-2-686
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages apt depends on:
ii  libc6                         2.3.6-15   GNU C Library: Shared libraries
ii  libgcc1                       1:4.1.1-5  GCC support library
ii  libstdc++6                    4.1.1-5    The GNU Standard C++ Library v3

Versions of packages apt recommends:
pn  debian-archive-keyring        <none>     (no description available)

-- no debconf information

Reply to: