[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#212344: apt: please add Glibc-based GNU/KNetBSD

Package: apt
Version: 0.5.12
Severity: wishlist
Tags: patch

The attached patch adds detection for Glibc-based GNU/KNetBSD systems.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux aragorn 2.2.25 #1 Fri Jun 20 19:28:33 EST 2003 i686

Versions of packages apt depends on:
ii  libc6                      2.3.2-8       GNU C Library: Shared libraries an
ii  libgcc1                    1:3.3.2-0pre4 GCC support library
ii  libstdc++5                 1:3.3.2-0pre4 The GNU Standard C++ Library v3

-- no debconf information

diff -ur apt-0.5.12.old/buildlib/ostable apt-0.5.12/buildlib/ostable
--- apt-0.5.12.old/buildlib/ostable	2003-08-04 16:03:50.000000000 +0000
+++ apt-0.5.12/buildlib/ostable	2003-09-22 15:23:26.000000000 +0000
@@ -9,6 +9,7 @@
 # These are used by Debian
 [^-]*-linux-.*   linux
 [^-]*-kfreebsd.*-gnu   freebsd
+[^-]*-knetbsd.*-gnu   netbsd
 [^-]*-gnu[^-]*   hurd
 # These are samples. 

Reply to: