[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#151835: apt-get should show which archive has invalid signature

Package: apt
Version: 0.5.4
Severity: important

A power failure during an apt-get upgrade caused some corrupt archives,
causing apt-get to print:

E: Invalid archive signature
E: Invalid archive signature
E: Invalid archive signature
E: Invalid archive signature
...Unpacking replacement fileutils ...
dpkg: error processing
 corrupted filesystem tarfile - corrupted package archive: Success
 dpkg-deb: subprocess paste killed by signal (Broken pipe)
apt-get should probably show which package has an invalid signature
(and, now that I think about it, possibly refuse to install the package
without being forced.)

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux halcyon 2.4.18 #1 Thu Mar 7 11:31:57 CST 2002 i686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8

Versions of packages apt depends on:
ii  libc6                         2.2.5-7    GNU C Library: Shared libraries an
ii  libstdc++2.10-glibc2.2        1:2.95.4-9 The GNU stdc++ library

-- no debconf information

To UNSUBSCRIBE, email to deity-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: