[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#532208: [libgl1-mesa-dri] Missing dependency?



Package: libgl1-mesa-dri
Version: 7.4.1-1
Severity: normal


--- Please enter the report below this line. ---


It seems to me that libgl1-mesa-dri is missing a dependency:


After updating the xorg core and server (intel) to unstable,
apt-get install -t unstable xserver-xorg-video-intel xserver-xorg-core
xserver-xorg xserver-xorg-input-kbd xserver-xorg-input-mouse
xserver-xorg-input-synaptics
the kdm display manager couldn't start X anymore:


(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed
(/usr/lib/dri/i915_dri.so: undefined symbol: _glapi_tls_Context)
(EE) AIGLX: reverting to software rendering


As /usr/lib/dri/i915_dri.so belongs to libgl1-mesa-dri
and that package was already the unstable version 7.4.1-1, while
mesa-utils libglu1-mesa
were still the old testing version 7.0.3-7, i updated these two last packages to unstable and this solved the problem.


Isn't there a missing dependency?


ii libgl1-mesa-dri 7.4.1-1
ii libgl1-mesa-glx 7.4.1-1
ii libglu1-mesa 7.4.1-1
ii mesa-utils 7.4.1-1
ii xserver-xorg 1:7.4+1
ii xserver-xorg-core 2:1.6.1.901-2
ii xserver-xorg-input-all 1:7.4+1
ii xserver-xorg-input-evdev 1:2.2.2-1
ii xserver-xorg-input-kbd 1:1.3.2-3
ii xserver-xorg-input-mouse 1:1.4.0-2
ii xserver-xorg-input-synaptics 1.1.1~git20090510-1
ii xserver-xorg-input-wacom 0.8.3.2-1
ii xserver-xorg-video-intel 2:2.7.1-1




--- System information. ---
Architecture: i386
Kernel: Linux 2.6.29.3


Debian Release: squeeze/sid
990 testing www.debian-multimedia.org
990 testing security.debian.org
990 testing ftp.de.debian.org
950 unstable www.debian-multimedia.org
800 unstable ftp.de.debian.org
700 experimental ftp.de.debian.org
500 stable volatile.debian.org


--- Package information. ---
Depends (Version) | Installed
=============================-+-============
libc6 (>= 2.7-1) | 2.9-12
libdrm-intel1 (>= 2.4.5) | 2.4.9-2
libdrm2 (>= 2.3.1) | 2.4.9-2
libexpat1 (>= 1.95.8) | 2.0.1-4



Package's Recommends field is empty.


Suggests (Version) | Installed
========================-+-===========
libglide3 |







Reply to: