[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#280165: marked as done (ITP: dssi -- an API designed for software synthesis plugins with native user interfaces)

Your message dated Fri, 10 Feb 2006 08:20:41 -0800
with message-id <E1F7b0j-0001dH-5w@spohr.debian.org>
and subject line Bug#280165: fixed in dssi 0.9.1-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: wnpp
Severity: wishlist

 * Package name    : dssi
   Version         : 0.9
   Upstream Authors: Steve Harris (steve@plugin.org.uk)
                     Chris Cannam (cannam@all-day-breakfast.com)
                     Sean Bolton (musound@jps.net)
 * URL             : http://dssi.sourceforge.net/
 * License         : Interface: LGPL
                     Example programs: BSD / GPL / Public Domain
                     (full details at bottom of this ITP)
   Description     : an API designed for software synthesis plugins
                     with native user interfaces

DSSI (pronounced "dizzy") is an API for audio plugins, with particular
application for software synthesis plugins with native user interfaces.
DSSI is an open specification developed for use in Linux audio
applications, although portable to other platforms. It may be thought of
as LADSPA-for-instruments, or something comparable to VSTi.
The DSSI source package contains:
  * The specification, header file and documentation for the DSSI 0.9 API.
    (in the binary packages dssi and dssi-doc)
  * A complete DSSI host (jack-dssi-host) that can host any number of DSSI
    plugins with GUIs as a JACK application using the ALSA sequencer for
    MIDI input.
    (in the binary package dssi-host-jack)
  * A number of example plugins, including (just about) the simplest possible
    synth, another simple synth with GUI, a monotimbral sampler with GUI, and
    a wrapper for the FluidSynth SoundFont synth.
    (in the binary packages dssi-plugin-{simple,monotimbral,fluidsynth})

Copyright details (from README of dssi-0.9.tar.gz):

The DSSI API itself (dssi.h) is licensed under the GNU Lesser General
Public License.  See COPYING for details.

The jack-dssi-host is provided under a BSD-style license.  This means
you can do anything you want with it so long as you retain the
copyright attribution and license information.  See the source files
for details.

FluidSynth-DSSI is provided under the GNU General Public License.  See
fluidsynth-dssi/COPYING for details.

Licensing for the files in the examples directory may vary: please
check the individual files for details.  Most of them are in the
public domain, which means you can use them for anything you want.

Note from the ITPer: A full audit of all files will be performed and
details placed in debian/copyright during packaging.

Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
Source: dssi
Source-Version: 0.9.1-1

We believe that the bug you reported is fixed in the latest version of
dssi, which is due to be installed in the Debian FTP archive:

  to pool/main/d/dssi/dssi-dev_0.9.1-1_all.deb
  to pool/main/d/dssi/dssi-example-plugins_0.9.1-1_i386.deb
  to pool/main/d/dssi/dssi-host-jack_0.9.1-1_i386.deb
  to pool/main/d/dssi/dssi-utils_0.9.1-1_i386.deb
  to pool/main/d/dssi/dssi_0.9.1-1.diff.gz
  to pool/main/d/dssi/dssi_0.9.1-1.dsc
  to pool/main/d/dssi/dssi_0.9.1.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 280165@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Mark Hymers <mark.hymers@ncl.ac.uk> (supplier of updated dssi package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 14 Jan 2006 15:52:55 +0000
Source: dssi
Binary: dssi-utils dssi-host-jack dssi-dev dssi-example-plugins
Architecture: source i386 all
Version: 0.9.1-1
Distribution: unstable
Urgency: low
Maintainer: DSSI Maintainers <pkg-dssi-devel@lists.alioth.debian.org>
Changed-By: Mark Hymers <mark.hymers@ncl.ac.uk>
 dssi-dev   - Header file for compiling DSSI plugins and hosts
 dssi-example-plugins - Example DSSI plugins
 dssi-host-jack - An example DSSI host
 dssi-utils - Command-line utilities for sending commands to DSSI plugins
Closes: 280165
 dssi (0.9.1-1) unstable; urgency=low
   * Initial upload.  Closes: #280165.
 44f97b64a09ed3f389a0c060a7165761 810 libdevel optional dssi_0.9.1-1.dsc
 1a353c3ae80328cded838853ddf52164 390757 libdevel optional dssi_0.9.1.orig.tar.gz
 dc78ed228f06cbcfc52452f33e95e815 17437 libdevel optional dssi_0.9.1-1.diff.gz
 4f50910ad180c54fcb7ff006179fb7c5 9270 libdevel optional dssi-utils_0.9.1-1_i386.deb
 d2bf87472e7f342a76c1fa391b3a2315 20170 libdevel optional dssi-host-jack_0.9.1-1_i386.deb
 cbd0fcc32766d99af8593badcd0a4d31 57692 libdevel optional dssi-example-plugins_0.9.1-1_i386.deb
 2ab6b9e3970e6a6e106f89a1094be9ba 37666 libdevel optional dssi-dev_0.9.1-1_all.deb

Version: GnuPG v1.4.2 (GNU/Linux)


--- End Message ---

Reply to: