[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

AW: apt-get install refuses to installs older versions of dependencies

Hi Tomás,

Thank you very much for suggesting `--allow-downgrades` and your additional explanations.

Unfortunately, I get the same error as before:
$ sudo apt-get install --allow-downgrades foo=1.0.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
foo : Depends: bar (= 3.0.0) but 4.0.0 is to be installed
E: Unable to correct problems, you have held broken packages.

The package `bar` is not pre-installed.


Reply to: