[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hplip and scanning not working on Jessie

On 12/06/2015 04:41 AM, Selim T. Erdoğan wrote:
On Sat, Dec 05, 2015 at 07:21:49PM -0800, Marc Shapiro wrote:
I recently upgraded to Jessie, using sysvint-core as my init and am having
some printer problems.

I got the printer working.  CUPS was apparently uninstalled during the
upgrade.  I had noticed that some CUPS files were being removed, but it
looked like replacements for them were being installed. Anyway, I installed
CUPS, found what driver it wanted (printer-driver-hpcups) and installed it,
printer-driver-hpcups is a dependency of hplip, so I would have expected
it to be already installed.

That was before I realized that hplip had be uninstalled, as well, so that could explain why it was not there at the time.

No matter which tool I tried to run, with the exception of hp-check, I get
the following error:

# hp-setup
Traceback (most recent call last):
   File "/usr/bin/hp-setup", line 45, in <module>
     from base import device, utils, tui, models, module, services, os_utils
   File "/usr/share/hplip/base/device.py", line 42, in <module>
     import status
   File "/usr/share/hplip/base/status.py", line 59, in <module>
     import hpmudext
ImportError: libnetsnmp.so.15: cannot open shared object file: No such file
or directory
This is strange.  libsnmp15 was in wheezy and a dependency of hplip 3.12.
In Jessie, hplip is 3.14 and depends on libsnmp30.  You seem to have
hplip 3.14, so why it's looking for the file above is a mystery.

HPLIP-Version: HPLIP 3.14.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for debian
distro  8.2 version
Maybe try purging and re-installing hplip?

I just tried purging libhpmud0, which also removed libsane-hpaio, hpijs, hplip, printer-driver-hpcups, printer-driver-hpijs, and printer-driver-postscript-hp.

I then manually purged all of the additional packages removed above to get rid of all config files. After that, I reinstalled hplip. No luck. Still getting the same results and hp-check still says that python-reportlab, libtool, and hpmudext are missing, but they are all installed and up to date:

|  General Dependencies |

error: reportlab Python-PDF-Lib OPTIONAL 2.0 3.1.8 MISSING 'reportlab needs to be installed' libcrypto OpenSSL-Crypto-Lib REQUIRED - 1.0.1 OK - pil Python-Image-Lib OPTIONAL - 1.1.7 OK - pyqt4-dbus PyQt4-DBUS REQUIRED 4.0 4.11.2 OK - libjpeg JPEG-Lib REQUIRED - - OK - libpthread POSIX-Threads-Lib REQUIRED - 2.19 OK - python-dbus Python-DBUS REQUIRED 0.80.0 1.2.0 OK - python-devel Python-SDK REQUIRED 2.2 2.7.9 OK - pyqt4 Python-Qt4 REQUIRED 4.0 4.11.2 OK - cups-devel CUPS-SDK REQUIRED - 1.7.5 OK - sane-devel SANE-SDK REQUIRED - 1.0.24 OK - libusb USB-Lib REQUIRED - 1.0 OK - sane Scan-Lib REQUIRED - 1.0.24 OK - cups-image CUPS-Image-Lib REQUIRED - 1.7.5 OK - libnetsnmp-devel SNMP-Networking-SDK REQUIRED 5.0.9 5.7.2 OK - python-xml Python-XML-Lib REQUIRED - 2.1.0 OK - python-notify Desktop-notifications OPTIONAL - - OK -

|  Compile Time Dependencies |

gcc gcc-Compiler REQUIRED - 4.9.2 OK - error: libtool Build-tools REQUIRED - - MISSING 'libtool needs to be installed' make GNU-Build-tools REQUIRED 3.0 4.0 OK -

|  Python Extentions |

cupsext CUPS-Extension REQUIRED - 3.14.6 OK - pcardext PhotoCard-Extension REQUIRED - 3.14.6 OK - error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of hpmudext. error: hpmudext IO-Extension REQUIRED - 3.14.6 MISSING 'Not Found or Failed to load, Please reinstall HPLIP'

|  Scan Configuration |

hpaio HPLIP-SANE-Backend REQUIRED - 3.14.6 OK 'hpaio found in /etc/sane.d/dll.conf' scanext Scan-SANE-Extension REQUIRED - 3.14.6 OK -


error: Failed to get Scanners information.



Missing Required Dependencies
error: 'libtool' package is missing/incompatible

Missing Optional Dependencies
error: 'python-reportlab' package is missing/incompatible

Total Errors: 3
Total Warnings: 1

Run 'hp-doctor' command to prompt and fix the issues.


Reply to: