Hello debian users,
I am having trouble dist-upgrading from squeeze-lts to wheezy.
I have been following these instructions to upgrade from pre-lts squeeze (didn't find any specific ones for lts):
The problem happens when it gets to apt:
dpkg: error processing apt (--configure):
subprocess installed post-installation script returned error exit status 2
configured to not write apport reports
Errors were encountered while processing:
Can't locate File/Find.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 .) at /usr/bin/debsums line 10.
BEGIN failed--compilation aborted at /usr/bin/debsums line 10.
E: Problem executing scripts DPkg::Post-Invoke 'if [ -x /usr/bin/debsums ]; then /usr/bin/debsums --generate=nocheck -sp /var/cache/apt/archives; fi'
Indeed, I cannot locate the File/Find.pm module on my system (with locate & grep). Trying to install it via cpan fails with "Can't locate autouse.pm
`apt-get -f install` fails with the same message as above.
I noticed the list of unmet dependencies included a bunch of vlc packages that I do not care about, so I tried getting rid of those, and it pares down the list of problem packages by about half:
# apt-get purge vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse libvlc5
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
consolekit : Depends: libck-connector0 (= 0.4.5-3.1) but 0.4.1-4 is to be installed
irssi : Depends: perlapi-5.14.2
libalgorithm-diff-xs-perl : Depends: perlapi-5.14.2
libapache2-mod-perl2 : Depends: perlapi-5.14.2
libapt-pkg-perl : Depends: libapt-pkg4.10 but it is not installable
libbsd-resource-perl : Depends: perlapi-5.14.2
libcurses-perl : Depends: perlapi-5.14.2
libdatetime-perl : Depends: perlapi-5.14.2
libdbd-mysql-perl : Depends: perlapi-5.14.2
libdbd-pg-perl : Depends: perlapi-5.14.2
libdbd-sqlite3-perl : Depends: perlapi-5.14.2
libdbi-perl : Depends: perlapi-5.14.2
libdevmapper1.02.1 : Depends: dmsetup (>= 2:1.02.74-8) but 2:1.02.48-5 is to be installed
libfcgi-perl : Depends: perlapi-5.14.2
libgd-text-perl : Depends: libgd-gd2-perl but it is not going to be installed
libhtml-parser-perl : Depends: perlapi-5.14.2
libio-pty-perl : Depends: perlapi-5.14.2
liblist-moreutils-perl : Depends: perlapi-5.14.2
libmouse-perl : Depends: perlapi-5.14.2
libnet-dns-perl : Depends: perlapi-5.14.2
libnet-libidn-perl : Depends: perlapi-5.14.2
libnet-ssleay-perl : Depends: perlapi-5.14.2
libnetaddr-ip-perl : Depends: perlapi-5.14.2
libparams-classify-perl : Depends: perlapi-5.14.2
libparams-util-perl : Depends: perlapi-5.14.2
libparams-validate-perl : Depends: perlapi-5.14.2
libperl5.14 : Depends: perl-base (= 5.14.2-21+deb7u2) but 5.10.1-17squeeze6 is to be installed
libsocket6-perl : Depends: perlapi-5.14.2
libterm-readline-gnu-perl : Depends: perlapi-5.14.2
libuuid-perl : Depends: perl-base (>= 5.14.2-13) but 5.10.1-17squeeze6 is to be installed
libwmf0.2-7 : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
libyaml-syck-perl : Depends: perlapi-5.14.2
perl : Depends: perl-base (= 5.14.2-21+deb7u2) but 5.10.1-17squeeze6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
I am not sure if "(or specify a solution)" is referring to some method other that purging/removing packages the way I tried above.
I do notice that there are still what look like squeeze security backports that want to be installed
My sources.list.d is empty & my entire sources.list is:
1 # non-free is required for tg3 nic firmware
2 # W: Possible missing firmware /lib/firmware/tigon/tg3_tso5.bin for module tg3
3 # W: Possible missing firmware /lib/firmware/tigon/tg3_tso.bin for module tg3
4 # W: Possible missing firmware /lib/firmware/tigon/tg3.bin for module tg3
7 # *-updates replaces "volatile" @ squeeze (virus defs, tz data, etc)
What would be the recommended way of proceeding with this upgrade?
Thanks for reading,
(Sorry for sending to list from gmail, it is my mail server I am upgrading)