[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libssl1.0.0:amd64 1.0.1e-2+deb7u7 upgrade fail



Anyone else having problems with the wheezy openssl security update that was just released?

I'm looking into what is failing in the postinst script, but haven't IDed the cause yet.


$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
 libssl-dev libssl-doc libssl1.0.0 openssl
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
...
Fetched 4,901 kB in 0s (19.3 MB/s)
Reading changelogs...
Preconfiguring packages ...
debconf: warning: possible database corruption. Will attempt to repair by adding back missing question libssl1.0.0/restart-services.
debconf: warning: possible database corruption. Will attempt to repair by adding back missing question libssl1.0.0/restart-failed.
(Reading database ... 62423 files and directories currently installed.)
Preparing to replace libssl-doc 1.0.1e-2+deb7u6 (using .../libssl-doc_1.0.1e-2+deb7u7_all.deb) ...
Unpacking replacement libssl-doc ...
Preparing to replace libssl-dev 1.0.1e-2+deb7u6 (using .../libssl-dev_1.0.1e-2+deb7u7_amd64.deb) ...
Unpacking replacement libssl-dev ...
Preparing to replace libssl1.0.0:amd64 1.0.1e-2+deb7u6 (using .../libssl1.0.0_1.0.1e-2+deb7u7_amd64.deb) ...
Unpacking replacement libssl1.0.0:amd64 ...
Preparing to replace openssl 1.0.1e-2+deb7u6 (using .../openssl_1.0.1e-2+deb7u7_amd64.deb) ...
Unpacking replacement openssl ...
Processing triggers for man-db ...
Setting up libssl-doc (1.0.1e-2+deb7u7) ...
Setting up libssl1.0.0:amd64 (1.0.1e-2+deb7u7) ...
Checking for services that may need to be restarted...done.
Checking init scripts...
dpkg: error processing libssl1.0.0:amd64 (--configure):
subprocess installed post-installation script returned error exit status 10
dpkg: dependency problems prevent configuration of libssl-dev:
libssl-dev depends on libssl1.0.0 (= 1.0.1e-2+deb7u7); however:
 Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing libssl-dev (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openssl:
openssl depends on libssl1.0.0 (>= 1.0.1e-2+deb7u5); however:
 Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing openssl (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libssl1.0.0:amd64
libssl-dev
openssl
E: Sub-process /usr/bin/dpkg returned an error code (1)

Attachment: smime.p7s
Description: S/MIME cryptographic signature


Reply to: