[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xorg (fglrx, radeon, radeonhd, vesa) not working after upgrade

Stefan Bellon wrote :
> thveillon.debian wrote:
>> you'll be sorry to hear that your card is now a "legacy" one
>> according to AMD/ATI. They dropped support for a bunch of card with
>> the 9.4 release.
>> http://support.amd.com/us/gpudownload/linux/legacy/Pages/radeon_linux.aspx?type=2.4.2&product=
> No, if you have a close look at this page, you'll notice that a lot of
> cards are legacy, but not the X1400 one which my ThinkPad T60 has.

Yep, it's not named on the page, which I guess is a mistake, but you
will be redirected on the "legacy" page if you try to select a driver
from the AMD/ATI drivers selection page, so...

>> So I guess the Sid version is too new for you, you can install an
>> older fglrx (9.3) or stick with the free driver.
> But nevertheless, even if my X1400 was legacy and not supported in
> fglrx anymore (which is not the case), then the main problem is that
> neither radeonhd, nor radeon, nor plain vesa seem to work right now.
> THIS is my problem.

So maybe you have another problem on top of that, some leftovers from
fglrx installation that don't go well with free drivers, like
proprietary libGL maybe ?

> Still being very grateful for hints.
> Greetings,
> Stefan

Good luck,


Reply to: